Incorrect permissions on Windows Search directories ERROR

Windows 8 x64 (placed on top of Windows 7).
The last time I have noticed that the search does not find all of the files and cannot find an Outlook message.
When I run an "Search and indexing" dialog, and perform the correction action Incorrect permissions on Windows Search directories" diagnostic is appears. Status: Not fixed.
Tried:
- The restart of the system.
- Restart in the "Diagnostic mode" (msconfig).
- The restructuring of the index.
- Change folder to the index.
- Disabling/enabling a component of Windows Search (control Panel).
Did not help :( 
Hi,
 

Thank you for posting your question on Microsoft Community!

 

After going through your issue description, it appears that you have an issue with Search and indexing. However, in order to guide you in the right direction; I will need some more information. Please help me by answering the questions mentioned below.

 
1. Search and indexing was working fine earlier?
2. Did you make any changes prior to the issue?
 

Let’s find the issue cause and try fixing it by performing the following method.
 

 

Take complete ownership of the path C:/Program data/ Microsoft/Search/Data and check the issue status.

 

a.       Open a folder with protected system files

b.      Right-click on a file and click on Properties

c.       Go to the tab Security

d.      Click on Permissions to take ownership of the file

e.      At the top click on the hyperlink Change owner:

f.        Now enter the username of your account. Optionally click on Check names to verify that the name is correct

g.       It should now list YOU as the owner of the file. CLICK ON APPLY

h.      Select your username from the list (back on the Security tab) and click on Edit. Confirm the UAC prompt

i.         Select your username again and check the box Full Control

j.        Click on Apply

 


You can also refer to:
Indexing and Search: Frequently asked questions
http://windows.microsoft.com/en-IN/windows-8/search-index-faq
 
If the issue still persists, I would suggest you to provide logs of the Event Viewer  to assist you further.

11 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thank you.
I have changed owner and will be to observe for system behavior 

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,

 

Thank you for your reply.

 

Please update the issue status aftre the observation.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

All the same :((
Test is OK in user mode, but return same error message in admin mode.
Documents can be found by name, bun only some of them by content.
No one Outlook's and OneNote's item can be found from Windows 8 Search interface

4 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Microsoft has ready not tried to resolve this problem.  The answer is quite simple.  Local the folder <<C:\ProgramData\Microsoft\Search>>.  The owner and permissions have to be replaced on the entire directory tree.

 

Detail instructions to accomplish this: 
>Right click it,
>select properties,
>select Security Tab,
>Advanced button
>Owner Tab
>Edit
>Select/Add your user ID and select "Replace Owner on subcontainers and objects"
>Click OK
>  Back completely out of the properties
>Right click <<C:\ProgramData\Microsoft\Search>>
>select properties,
>select Security Tab,
>Advanced button
>Permissions Tag
>Permissions button
>Add button
>enter name, check name, and select, and OK
>Back in the Permissions window: Select "Included inheritable..."  and "Replace all child object permissions ..."
>  OK out of the properties panels

May require a reboot to restart indexing.  Be sure to recheck the <<C:\ProgramData\Microsoft\Search>> for permissions and ownership.  My corporate security settings reset this each day.   What fun.

175 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Didn't work for me.

Weird thing is, results show when you first boot up. But after a few minutes, no settings results are returned.

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

did you ever get this fixed

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Only after system re-install

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,


Run the DISM tool and check. This will help you to repair the corrupt system files, this might help you,

Refer to “Windows 8.1, Windows 8, Windows Server 2012 R2 or Windows Server 2012 ” from the following link. Please ignore the title.

http://support.microsoft.com/kb/947821/en-us

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

 
 

Question Info


Last updated October 13, 2020 Views 87,145 Applies to: