Windows Media Player 12 on Windows 8 not working!

when opening media files, it said SERVER EXECUTION FAILED. But if I use the Music App available on win8, it plays but with no background-- I cant even pause, rewind and see the playlist. I just have Windows Defender as my anti-virus. What should I do?

Question Info

Last updated March 24, 2018 Views 701 Applies to:

Hi Ann,


I would suggest you to follow the troubleshooting methods and check if it helps.


Method 1: Run the Windows media player settings troubleshooter and check.


Follow the steps to run the troubleshooter:


a)      Press Windows key + C on your keyboard to show the Charms bar.

b)      Type Troubleshooting and click Troubleshooting under Settings.

c)       Now click on Programs.

d)      Click on Windows media player settings to run the troubleshooter.

e)      Click on Windows media player library to run the troubleshooter.


Method 2: Add Local Service to Administrators group using command prompt:


a)      Press Windows key + X and click on Command Prompt (Admin).

b)      Type the following command line and press Enter.

NET LOCALGROUP administrators "NT Authority\Local Service" /ADD

You will receive a message “The command completed successfully”.


Method 3: I would suggest you to stop and restart the Windows Media Player Network Sharing Service and check for the issue.


a)      Press Windows key + R to open the Run Dialog box.

b)       Type Services.msc and hit Enter.

c)       Now look for Windows Media Player Network sharing service and click on Stop. Click on OK.

d)      Close the services window and then re-open it. Navigate to the same location and then click on Start.

e)      Click on OK.


Restart the computer and check if the issue still persists.


Method 4: I would suggest you to uninstall and reinstall Windows Media player and check if it helps.


a)      Press Windows key + W on the keyboard.

b)      Type Windows features and click Enter.

c)       Click on settings.

d)      Click on Turn Windows Features on or off.

e)      Locate Media features.

f)       Expand Media features and Uncheck the box which states Windows Media player.

g)      Click on Yes.

h)      Click on OK.

i)        Now click on Restart now.

j)        Navigate to the same location and check the box for "Windows Media player".

k)      Click on OK.


Regarding Music App issue I would suggest you to refer to the link below and check;


What to do if you have problems with an app


In many cases, the Apps will automatically notify if there are problem with any app and try to fix the problem. If the Apps don’t notify the problem you are experiencing problems with an app.


I would suggest you to run the Apps troubleshooter from the mentioned link above.

Refer to the link below for reference:


Turn Windows features on or off


If you need further assistance regarding Windows, please feel free to post. We will be happy to help you.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.