Windows 8 : (Error The Boot Configuration Data file is missing or contains errors)

I can not log on to Windows 8. I do not have recovery disk and can not launch F11 or F8. I am using a Lenovo H520s. I am very sad that my computer can not log in and I have to use an Ubuntu Live CD to use the computer.
 

Question Info


Last updated May 18, 2020 Views 14,339 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Make a system repair disc from another win8 computer with same number of bits as yours.   Or borrow one or any win8 install or upgrade disc will have the repair environment option on it as a choice.   I've read that win7 system repair disc (of same bits) will work too.

Boot from it and Try the automatic repair.

~
Microsoft Bob came back after a 20 year makeover, and with a new name. Cortana!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

This is only my Windows 8 Computer but I have a Windows 7 Computer and I have a upgrade CD of Windows 7 Home Premium. Is this OK? I have a Lenovo Driver and Application CD but it is not bootable.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Try your win7 CD if the same bits .  Use its startup repair option once you get booted to it.  Or you can use its Command Prompt and the following command, becareful with the spaces ;

Bcdedit /set {bootmgr} displaybootmenu yes

 

That command will enable the F8 key to function on your win8 start up.

~
Microsoft Bob came back after a 20 year makeover, and with a new name. Cortana!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

It came up with:

The boot configuration data store could not be opened. The requested system device can not be found.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,

 

It appears that you were able to get the command prompt, so give this a try...

There is a easier way to do this, but sometimes when you have multiple partitions, the .CMD can't find the right one... I haven't personally tried this, but have received replies that it worked.

 

a. Boot the computer using theWindows 8 bootable DVD. ( or Repair Disk...or your Win 7 disk, whatever you used)
b. On the ‘Windows Setup’ wizard click on ‘Next’ and click on ‘Repair your computer’.
c. You will then see a blue screen and an option to choose.
d. Click on ‘Troubleshoot’ then click on ‘Advanced Option’ and then click on ‘Command Prompt’.
e. Type these commands on the Command Prompt:
bcdedit /export C:\BCD_Backup
c:
cd boot
attrib bcd –s –h –r
ren c:\boot\bcd bcd.old
bootrec /RebuildBcd
(Press Enter after each line of command)
Following these steps will re-build the BCD.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

C: is not a drive. The F: drive is a Windows Partition (strangely) but it is increasable in the CMD and Ubuntu. It only shows it in Windows Setup and Ubuntu Installer. 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,

 

When you have extra partitions\drives, the drive lettering sometimes gets scrambled as compared to what it is after booting.

 

You seem to have figured it out, but from the CMD Prompt, type in Dir *:\, where the the * represents a letter from C:\ to how ever many drives\partitions you have. BTW...There is a space after Dir...

 

Confirm which drive letter is currently assigned to your windows partition, and substitute it for the C:.

 

Also,   It is possible that the reason that "F:\" is inaccessible is that your boot loader (Ubuntu?) has marked it as "Hidden", and possibly "Inactive".  This is common in some bootloaders to keep the unused OS from interfering and\or becoming corrupted...

 

If this is the case, you may need a 3rd party partitioning\disk management program on a bootable CD to "Unhide" it and make "Active".... Being "Active" may not be necessary. I haven't played with this lately to remember specifically.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I managed to acess it in Ubuntu with the
/usr/bin/udisks --mount /dev/sda4 command but how do I mount it in Windows CMD? And the F: drive is not hidden and I am using a live CD of Ubuntu.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,

 

When you get to the command prompt, type in F: and hit enter...

Then try accessing the repair commands I mentioned, or GoBonkers... except use F: instead of C:

 

Ubuntu and Win 8 are a bit different I think... I know nothing about Linux...

It could be hidden for Win 8, and Linux doesn't  "Recognize" the windows setting...

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

It comes with "The disk isn't ready.".

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.