Shows winlogon.exe no disk error on shutdown. How do I remove the error?

Whenever I try to shut down (Charms, Settings, Power, Shutdown) and error appears and it won't let me shut down:

winlogon.exe - No Disk

"There is no disk in the drive. Please insert a disk into drive I:"

The drive it says changes every time, but it is always a non-existent one.

Please help me fix this - I have tried refreshing my PC, resetting it, re-downloading Windows 8 and even burning an ISO to a disk but it still shows the error. I didn't have this problem on the same machine with the Consumer Preview, or Windows 7.

 

Thanks. Edit: I am using a Dell Inspiron desktop.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

I have same problem - Dell Inspiron 1564

Was OK in Consumer Preview

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I also had this error, but it was not just the card reader. It was every drive on the computer--hard drives, hard drive partitions, empty usb drives, card readers with no disk, etc. in an endless loop requiring a hard shutdown. I corrected it by disabling Fast Start in Power Options, System Settings (power button settings) Change options currently unavailable, uncheck Fast Start. You can type 'Shutdown Settings' on the metro page and select search Settings to get to it quickly.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I corrected it by disabling Fast Start in Power Options, System Settings (power button settings) Change options currently unavailable, uncheck Fast Start. You can type 'Shutdown Settings' on the metro page and select search Settings to get to it quickly.


That worked for me,

 

Thanks!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thanks. That works!

Step by step the 'fix' is:

 

1) From the Metro "Start" page type "Shutdown Settings"

2) Click the "Settings" Icon on the right of the screen.

3) Click "Change what the power buttons do" on the left of the screen.

4) Click "Change settings that are not currently available"

5) Scroll to bottom of Dialog box.

6) Uncheck the box titled "Turn on fast startup (recommended)."

7) Click "Save Changes" button.

8) Exit Power Options Dialog box.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I upgraded from Consumer Preview yesterday ... and got the same error when I tried to Shutdown last night ... and again tonight.

 

It will not let me delete the error message (i.e. 'X'), Cancel, Try Again, or Continue ... I have to hold the power button down to power off.

 

I also have a Dell Inspiron ... with a SD Card Reader;  which I have never used, and would remove, but I would lose my USB ports in the front of the PC if I did.


Also have a Dell Desktop... I was able to right-click 'Disable' all 5 '...USB Device' entries under the 'Disk drives' tree in Device Manager and that got rid of 5 popups. Now it shuts down cleanly and completely.     

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I found that if I signed out of my user profile, then go back to the sign on page to shut down that it will totally circumvent the error message all together.
Christopher

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I'm getting this issue as well. Only way to shut down is a hard shut down by holding in the power button until the computer powers off.

My specs: HP Pavilion - Intel Core i5 - 3.10GHz - 8 GB memory - nVidia GeForce GT 520 (1 GB)


Hopefully an update from Microsoft will address this. Removing my card reader is NOT an option as I use it a lot.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

The other option is to disable Fast Startup (Power Options, Choose what the power buttons do - in the sidebar), but this makes startup as slow as Windows 7.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thanks! Seems to work.

Though Microsoft really need to address this issue.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I was able to right-click 'Disable' all USB Devices entries under the 'Disk drives' tree in Device Manager and that got rid of popups. Now it shuts down cleanly and completely.     

 

I tried this fix this morning ... Only Disabling the USB Devices under Disk Drives in Device Manager (I left my three Hard Drives Enabled).  Doing this, also fixed my Shut Down errors.

 

I never use the SD/CF/MS/xD/SM Card Readers ... so, I Enabled Fast Start again.

 

Until they fix this ...

 

1) If you need the Card Readers, then Disable Fast Start.

 

2) If you do not need the Card Readers, then Disable them.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

 
 

Question Info


Last updated September 17, 2013 Views 13,321 Applies to: