Windows Defender not working.

I have recently up[graded a computer from Windows 7 Home Premium to Windows 8 Pro on 26/10/2012.

Windows Defender worked OK after the upgrade up until 28/10/2012 then it stopped working.. 

The initial error message was that Windows Defender was turned off and couldn't be started every time I tried to start it.

I went into the Group Policy editor Local Group Policy\Computer Configuration\Administrative Templates\Windows Components\Windows Defender and Disabled 'Turn Off Windows Defender'.

I could then start Windows Defender.

When I try to start Windows Defender I now get the following errors.

Couldn't start the Windows Defender service.

When I check in Services the Windows Defender Service IS running and is set to Automatic (trigger)

I also get the error message when trying to start the anti-virus protection by clicking on the red Enable button in Windows Defender home page.

The group or resource is not in the correct state to perform the requested operation.

The next error message says:

Virus and Spyware definitions are out of date.

When I go to the Update tab and try to update it appears to work with the definition last update date as the current date, and has the correct virus and spyware definitions number (1.139.1454.0)

However it says Definitions created on: 1/01/1970!

I have deleted the Windows Defender folder from C:\Program Data\Microsoft\ to force a complete download of the latest definitions folder in Windows update. 

Windows Update downloads and installs the latest definitions file successfully, but in Windows Defender Update it still says the File Creation Date is 1/01/1970!

Can anyone help?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

 
 

Question Info


Last updated August 20, 2020 Views 4,242 Applies to: