windows could not start the firewall on local computer error code 2

I have tried all I believe I can try. I was getting the error 0x80070424 and then after fixing some registry errors and countless "sfc/scannow" in the command prompt, that error is finally gone.

 

Now I have another problem. When I go and edit the Firewall setting it doesn't do anything.

 

When I go to services the service is there but will not start. It gives me the specific error code 2. 

 

Any help will be gladly appreciated.

Hi,

 

Thank you for reaching out to the Microsoft Community!

 

Based on the description, it appears that you are getting an error code 2 while trying to start windows firewall service.

 

-Were there any recent changes made on the computer prior to the issue?

 

I can understand the inconvenience caused to you. I will certainly help you out with this issue.

 

Let’s try these methods and check if it helps.

 

Method 1:

 

Run the Fix it from the link to fix the Windows Firewall Service problems and check.

 

Diagnose and fix Windows Firewall service problems automatically

http://support.microsoft.com/mats/windows_firewall_diagnostic/en-us

 

 

Method 2: Run a virus scan

 

I would suggest you to scan the computer using Windows Defender

http://windows.microsoft.com/en-US/windows-8/windows-defender#1TC=t1

 

Note: In Windows 8 and Windows RT, Windows Defender provides the same level of protection against malware as Microsoft Security Essentials. You can't use Microsoft Security Essentials with Windows 8 or Windows RT, but you don't need to—Windows Defender is already included and ready to go.

 

Method 3: Perform System restore

 

Follow method 2 from the following link.

http://support.microsoft.com/kb/2700567#method13

 

 

Windows Firewall from start to finish

http://windows.microsoft.com/en-US/windows-8/windows-firewall-from-start-to-finish

 

If the issue persists or you have further questions on Windows, please do not hesitate to let us know. We will be glad to help you.

K.Z. Sharief Khan
Ex-Microsoft Forum Moderator

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have done all of the steps but i have the same problem all the time i cant do it i have avast running but with no firewall can i have some help please also my windows defender wont start aswell saying '' an error has occurred in the program during initialization. If this problem continues please contact your system administrator error code 0x80073b01 Help would be appreciated 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Tomek,

 

 

Let’s try these methods and check if it helps.

 

 

Method 1: Disable Avast temporarily and check.

 

If the issue persists, please do not forget to enable the Avast.

 

 

Method 2: Take ownership of Windows Defender.

 

 

a.      Open C: drive, double click on Program files.

 

b.      Right-click on Windows Defender, click on Properties, and then click the Security tab.

 

c.       Click Advanced, and then click the Owner tab.

 

d.      Click Edit, and then do one of the following:

 

◦ To change the owner to a user or group that is not listed, click Other users and groups and, in Enter the object name to select (examples), type the name of the user or group, and then click OK.

 

◦ To change the owner to a user or group that is listed, in the Change owner to box, click the new owner.

 

e.       (Optional) To change the owner of all subcontainers and objects within the tree, select the Replace owner on subcontainers and objects check box.

 

 

Please update us with the results. We will be happy to assist you further.

K.Z. Sharief Khan
Ex-Microsoft Forum Moderator

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

It still does not work when i try to start it in services it pops up saying <Failed to Read Description. Error Code: 15100


And as of for firewall i disabled avast and i tried to turn it on is services and  i get a pop up saying '' Windows could not start the Windows Firewall service on local computer.

Error 1053: The service did not respond to the start or control request in a timely fashion.

More help would be appreciated.

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Tomek,

 

Let’s try these steps and check if it helps.

 

When a service starts, the service communicates to the Service Control Manager how long the service must have to start (the time-out period for the service). If the Service Control Manager does not receive a "service started" notice from the service within this time-out period, the Service Control Manager terminates the process that hosts the service. This time-out period is typically less than 30 seconds. If you do not adjust this time-out period, the Service Control Manager ends the process and the attached debugger while you are trying to debug. To adjust this time-out period, follow these steps:

 

a.       Press Windows Key + R, type regedit.exe and hit enter.

b.      Navigate to the following key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control

c.       Right-click on the above key and choose New, then DWORD Value.

d.      Type ServicesPipeTimeout as the name for it and press ENTER.

e.       Right-click on the ServicesPipeTimeout value and choose to Modify it.

f.       In the Base section click Decimal.

g.       In the Value data text box type for example 60000 as the value of timeout period and click OK.

h.      Restart the computer.

 

Note: The computer needs to be restarted for the Service Control Manager to apply this change.

 

Registry disclaimer: Back up the registry

Do let us know about the results. We will be happy to assist you further.

 

K.Z. Sharief Khan
Ex-Microsoft Forum Moderator

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I still have the same problem with windows defender the same pop up comes up, for windows firewall when i start it in services i get a pop up saying

Windows could not start the Windows Firewall service on local computer.For more information,review the System Event Log. If  this is a non-Microsoft service, contact the service vendor, and refer to service-specific error code 2.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

 
 

Question Info


Last updated June 14, 2020 Views 3,555 Applies to: