Pinned items don't open application as Administrator.

Using Windows 8 Pro, I have some application shortcuts pinned to the Taskbar and set to run as Administrator. Starting the applications from the icon runs them as Administrator, as expected. However, starting the applications from one of their pinned jump-list items does not start the application as Administrator.

For instance, I have Visual Studio 2012 pinned to the Taskbar and my most-used solutions are pinned within the jump-list. Launching these solutions from the jump-list opens VS2012 in non-Administrator mode. This means that my web projects cannot attach to my local IIS installation, since Administrator privileges are required for that to occur.

The workaround is to open VS2012 and then open the solution from within - but this is annoying, cumbersome and not how it worked in Windows 7.

Will this be fixed in a future release or is there a way to "fix" this now, within the registry or otherwise?

Hi Josh,

Thank you for posting your question in the Microsoft Community.

From the issue description, it appears that you are having problems with running pinned jump lists from the start screen as administrator.

Please answer the following questions so that I could assist you further:

  1. Have you made any recent changes to your computer?
  2. Are you receiving any error messages?
  3. Do you have a parallel operating system installed?

Try the below steps and get back to me with the results:

  1. Re- pin
    This might be a recent issue caused by certain items. Try re- pinning apps on your start screen and try to manually run them from the start screen( by right- clicking).
  2. Icons
    Actual icons work better than start screen items( that's my opinion). Hence, place the tiles that you want to in a folder and select 'Run as Administrator', the way you do for other operating systems.
  3. Individual
    I know that Jump lists are a convenient feature, but If nothing works, I guess you will have to pin individual items on the start screen to avoid using jump lists.

If this does not solve the problem or you need further assistance, reply to this post.

 

Ashwin

If this answered your question, click the 'Mark as Answer' button below my post

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I'm not running pinned items "from the Start Screen", but from the Taskbar.

  1. This has been an issue since I installed Windows 8 many months ago; it is not something that recently stopped working.
  2. There is no error message, the application just doesn't open as Administrator.
  3. I do not have another OS installed on this machine.
Thanks.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Try the given steps and also try with another set of files.

As you said that you tweaked the UI, you might be having the start menu. If you don't you can also get it here: http://www.stardock.com/products/start8/

See if jump lists work there.

 

Ashwin

If this answered your question, click the 'Mark as Answer' button below my post

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I did, it still doesn't work.

I didn't "tweak the UI" - this is a normal Windows 8 installation.

I'm not interested in installing 3rd party apps to restore the start button - I just want to report that this issue exists (and hope Microsoft fixes it in an update, soon).

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Might get resolved if noticed. So try to spread the word.

 

Ashwin

If this answered your question, click the 'Mark as Answer' button below my post

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

@Ashwin0: just admit you don't have a slightest clue what JoshAtSSS's talking about. He's made it perfectly clear in his question and your subsequent answers are just ridiculous and nonsensical.

Some Windows 8 expert should take this ticket. YOU SHOULD ESCALATE THIS and not ask the user to "spread the word".

Ridiculous support.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Did you ever get this to work? I have the exact same problem... pretty ridiculous that you need to run Visual Studio 2013 as administrator to develop web apps with regular IIS (not express) in the first place... even with user account control turned off.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

7 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

You can also fix this by editing a value in the registry - see the accepted answer on my question, here: http://superuser.com/questions/482368/make-jumplist-shortcut-always-run-application-as-administrator

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

 
 

Question Info


Last updated May 4, 2020 Views 2,415 Applies to: