Permission error - Failed to enumerate objects in the container. Access is denied.

I'm trying to change the permissions of my libraries to my current user and although some of my folders are fine, a bunch of them are throwing up the error: "Permission error - Failed to enumerate objects in the container. Access is denied." when I try to change them. I can go into the folders and files manually and change them correctly, but it's a pain in the butt considering there are literally *hundreds* of files that this is coming up on.

Any ideas on how to fix?
 

Question Info


Last updated November 20, 2019 Views 473,300 Applies to:
Answer
Answer

I'm having the same problem, but with trying to include a media file folder on a separate hard drive than where I had installed windows 8. It has literally, thousands of files. To your question:

1. yes

2. yes, and any other folder on the drive.

3. In order to access the folder, I need permission!

 

Thanks for your help, this is severely frustrating.


Here is how I solved my issue -
1. On the root folder, right click, select properties, select security tab.
2. Click Advanced
3. The window that pops up should show the current owner. Click "Change." The "Select User or Group" pop up box appears.
4. In the text box, type in your current user name (you should be an admin), and hit the "Check Names" button. Your name will be replaced with the "official" system name (i.e.,preceded by computer name and back slash).
5. Click OK
6. The box disappears, sending you back to the Advanced Security Settings window.
7. A new tick box appears below owner, with the text "Replace owner on subcontainers and objects" Select this tick box.
8. I also selected the tick box "Replace all child object permission entries with inheritable permission entries from this object", but I think I had to run this twice - once with this box ticked and once without.
9. Make sure that "everyone" appears on the Permission entries window, if not, click add. The same box that appears in step 4 shows up again. Type everyone, click "Check Names" and then "OK"
9. Hit apply

I also see that the folder ownership can be changed to "everyone" - I haven't tried changing all my folder owners to this, but doing so might eliminate this issue altogether if the drive is moved to a different computer.

Hope this helps someone, this problem and lack of documentation was quite aggravating.

884 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.