No Longer Have Administrator Privileges with Choosing Update Settings with Administrator Account

Even though I set up my computer, under the Administrator Account to Automatically Download and Install Updates, I notice it is set for me having to actually check and download them AND I CANNOT CHANGE THE SETTING.  Downloads are no longer working.  I did do a Troubleshoot the other day and noticed, when I checked "Installed Downloads" that they had all worked.  Before I was getting FAILED statuses. 

However, today when I manually check for Downloads, I am told up front that the action has FAILED.   When I Troubleshoot, the results tell me I need to "Try troubleshooting as an Administrator."   I am in the Administrator account!   Troubleshooted again and it told me it was a Group Policy issue.  Went to Local Group Policy Editor, Local Computer Policy, Windows Settings, Local Policies, Security Options:  Policy:  Accounts: Administrator account status:  Disabled.   Double-clicked.  Changed to Enabled from Disabled.  Applied.  Saved.

However, I am getting the exact same message as before on Windows Update, "Change update settings."  I am not listed as having Administrator privileges so far as determining Windows Update settings.   Did this occur the first week I was up and running when DELL Support live tied into this computer?  i.e. Was this a remote change --- or is this an inherent flaw in Windows 8 Pro? 

I am NOT tech savvy.  I learn as I go.  Please be specific in the exact steps I should take to remedy this situation.  Thank you in advance for your qualified help.
|

Hi,

 

Welcome to Microsoft Community and thank you for the post.

 

It appears that you get error Try troubleshooting as an Administrator when you try to download the Windows updates. You have logged in as an Administrator user.

 

Let me ask you few questions.

 

1) Do you get this error with any particular Windows Update KB number?
2) Do you have any other Administrator account on your computer? If yes then do you face this issue with that account too?

 

 

Please check the error code in Update history and write back to us with the exact error code. Follow the steps given below to see update history.

 

a) Press Windows Key + X key on Desktop.
b) Select Control Panel.
c) Select Windows Update.
d) On the left had side select View Windows Update history.

 

Run as admin option when a specific program is running is different than administrator of the computer as it is only specific to the program and this option is enabled if the program requires elevation even though you are the admin

 

 

You can get this error when you do not have enough privilege to make changes to settings. I have few troubleshooting methods to suggest. Follow the troubleshooting given here.

 

 

Troubleshoot problems with installing updates
 
 
Refer the link given here.
 
 
Windows automatic updating: Frequently asked questions
 
 

Feel free to write to us if you face this issue again. We will be happy to assist you.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.


Thank you so very much for your reply and help.  I am sorry it has taken me so long to respond.  Please accept my apologies.  Some of the things you suggested, I had already done and some, quite frankly, I did not know how to do!
This is a very strange situation.  I am used to XP and being able to change my Update settings and have them remain as set.  I am reading Win7 forums and this seems to be a problem starting with 7 - sometimes involving malware.  This is a new computer (less than 2mo old) and nothing is on it that I did not purchase.  KIS, Sandboxie, Firefox, all used.  I do have AOL Software and a US Robotics exterior modem as backup to save on Wireless data usage. (AOL cannot be opened Sandboxed but I use Firefox on the side.) Besides KIS, I also ran WD on this computer and later will try more in-depth pro AV since, when I did a System Restore to the very earliest point [Show more restore points], I had full control of choices --- which stayed as is for awhile and then reverted back to me having lack of control over the settings.
MEANWHILE, THIS (below) IS WHAT I DID TO GET DOWNLOADS TO WORK AS DESIRED.  (I do not know what I am doing, I just started looking and clicking.)
From Local Administrator Account:  Settings [Charms Bar] > Search: Group Policy > Edit Group Policy > Local Group Policy Editor (window) > Local Computer Policy > Windows Settings > Security Settings > Local Policies > Security Options:  (Then to right-hand side of window): Administrator account status:  Enable.
Switched to Hidden Administrator.  This STILL did not let me set the Update choices.  The choice box was greyed out.  So, I did this:  Search: Group Policy > Edit Group Policy > Local Group Policy Editor (window) > Local Computer Policy > Computer Configuration > Administrative Templates > Windows Components > Windows Update:  (Then to the right-hand side of the window): Configure Automatic Updates:  Configure Automatic Updates (new window):  Enabled.  Make Update choice to Download but let me chose when in Install.  (Says it's for Vista, etc. but I had to do this in order to change it for Win8).  So, it seems I may have done some of what you suggested without me knowing what I was doing or understanding what you were telling me to do?!
Signed out of Hidden Administrator and, under Local Administrator, hid the built-in Administrator account again.
Next, Settings (charms bar) > Change PC Settings > Devices:  Download over metered connections:  ON.
I was then able to Download all Updates ---- but they automatically started to Install THEMSELVES which was NOT my option.  So far today - after all the updates and installation of such - my Update Selection is staying the same and I am able to choose it from my Local Administrator Account.  Maybe the issue is completely fixed and resolved.
I am enjoying the ease of Windows 8 but, with this quirk which has wasted huge amounts of my time and taken me away from what I should be doing instead [I can't afford an IT person and I am not one!], it is a disappointment to me in this particular area.  But overall I like it.

4/20/2013 UPDATE:  Kaspersky Internet Security is changing this setting.  Reference: forum.kaspersky.com    It is nothing else.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.


Thank you so very much for your reply and help.  I am sorry it has taken me so long to respond.  Please accept my apologies.  Some of the things you suggested, I had already done and some, quite frankly, I did not know how to do!
This is a very strange situation.  I am used to XP and being able to change my Update settings and have them remain as set.  I am reading Win7 forums and this seems to be a problem starting with 7 - sometimes involving malware.  This is a new computer (less than 2mo old) and nothing is on it that I did not purchase.  KIS, Sandboxie, Firefox, all used.  I do have AOL Software and a US Robotics exterior modem as backup to save on Wireless data usage. (AOL cannot be opened Sandboxed but I use Firefox on the side.) Besides KIS, I also ran WD on this computer and later will try more in-depth pro AV since, when I did a System Restore to the very earliest point [Show more restore points], I had full control of choices --- which stayed as is for awhile and then reverted back to me having lack of control over the settings.
MEANWHILE, THIS (below) IS WHAT I DID TO GET DOWNLOADS TO WORK AS DESIRED.  (I do not know what I am doing, I just started looking and clicking.)
From Local Administrator Account:  Settings [Charms Bar] > Search: Group Policy > Edit Group Policy > Local Group Policy Editor (window) > Local Computer Policy > Windows Settings > Security Settings > Local Policies > Security Options:  (Then to right-hand side of window): Administrator account status:  Enable.
Switched to Hidden Administrator.  This STILL did not let me set the Update choices.  The choice box was greyed out.  So, I did this:  Search: Group Policy > Edit Group Policy > Local Group Policy Editor (window) > Local Computer Policy > Computer Configuration > Administrative Templates > Windows Components > Windows Update:  (Then to the right-hand side of the window): Configure Automatic Updates:  Configure Automatic Updates (new window):  Enabled.  Make Update choice to Download but let me chose when in Install.  (Says it's for Vista, etc. but I had to do this in order to change it for Win8).  So, it seems I may have done some of what you suggested without me knowing what I was doing or understanding what you were telling me to do?!
Signed out of Hidden Administrator and, under Local Administrator, hid the built-in Administrator account again.
Next, Settings (charms bar) > Change PC Settings > Devices:  Download over metered connections:  ON.
I was then able to Download all Updates ---- but they automatically started to Install THEMSELVES which was NOT my option.  So far today - after all the updates and installation of such - my Update Selection is staying the same and I am able to choose it from my Local Administrator Account.  Maybe the issue is completely fixed and resolved.
I am enjoying the ease of Windows 8 but, with this quirk which has wasted huge amounts of my time and taken me away from what I should be doing instead [I can't afford an IT person and I am not one!], it is a disappointment to me in this particular area.  But overall I like it.

4/20/2013 UPDATE:  Kaspersky Internet Security is changing this setting.  Reference: forum.kaspersky.com    It is nothing else.

I have a similar unresolved problem having tried the same fixes as SedaryAC. Can someone explain in what way Kaspersky Internet Security is changing this setting?
I have Kaspersky on my PC and wonder if that is my problem.

Thanks.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Roger PBurt, I have come to appreciate the KIS safeguard and live with it.  Even now I am quite happily doing MS Updates.  Just go into Control Panel on "Download Tuesday" (or the next day, etc.) and then System Security and Check For Updates.   Works great. 
As to HOW they control this, that is above my level so I cannot even begin to undo their inner AV bowels.
This is my first experience using Kaspersky.  I'd used Norton before but that let in boogers.

Some of my initial problems so far as failed updates (as listed in my original posting) were coming from MS and their new operating system.  Apparently all those bugs have been fixed.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Roger PBurt, I have come to appreciate the KIS safeguard and live with it.  Even now I am quite happily doing MS Updates.  Just go into Control Panel on "Download Tuesday" (or the next day, etc.) and then System Security and Check For Updates.   Works great. 
As to HOW they control this, that is above my level so I cannot even begin to undo their inner AV bowels.
This is my first experience using Kaspersky.  I'd used Norton before but that let in boogers.

Some of my initial problems so far as failed updates (as listed in my original posting) were coming from MS and their new operating system.  Apparently all those bugs have been fixed.

Thanks,

I do seem to be administrator except for the updates which I have to check for. I am the only one who uses this PC.

I did consider a Refresh bit worry it may compound things. On Thursday we are supposed to be getting an upgrade to Windows 8.1 so I don't want to jeopardise anything. I'm not all that tech savvy and find some of the tech advice difficult to follow.

Anyway thanks again for replying..


Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

You're fine.  You don't need to Restore.
To do Updates manually, point your mouse cursor to the bottom right corner of the Windows 8 screen.  The closest symbol to appear on the right will look like a little gear.  That is SETTINGS, click on it. 
Next, in the list that appears, click on CONTROL PANEL.  In the window which pops up, click on SYSTEM AND SECURITY. 
Next, where it says WINDOWS UPDATE, click "Check for updates".  A new window will appear which says "Windows Update". 
Under the "Download and install updates" you can click on "x-amount of important updates are available".   A new window will open.
Check the ones or all -- with all chosen if there is a [check mark] by NAME --- that you want to download and then, at the bottom of that window, click on [Install]
Usually it's every second Tuesday of the month that MicroSoft releases new updates but, as you are signing off your computer, on the choice-of-users screen, Windows 8 will tell you if new updates exist down in the bottom right hand corner.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated October 20, 2018 Views 711 Applies to: