How to disable autologon in Windows 8 with accounts that don't use a password?

Hi,

I've installed Windows 8 Pro, and added 2 administrator accounts, one for me, and one for my wife. 
In Windows 7 i've always disabled autologon, since me and my wife both want our own settings, desktop, etc, so it showed the logon screen and we could click the avatar of our username to login on the desired account since we didn't have passwords. I used to enable this using 'control userpasswords2' or 'netplwiz'.

But whatever I do in Windows 8, it _always_ goes autologon to an account. No logon screen at all. I've even played with the register settings at HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon by changing AutoAdminLogon from 1 to 0, I have tried checking and unchecking the buttons at 'control userpasswords2' for “Users must enter a user name and password to use this computer” etc, but whatever I try, it keeps autologging in :(


Does anybody what I am doing wrong?

With kinds regards,

Ruben
Answer
Answer

Hi Ruben,

 

            I will first post my solution, then explain:

 

1. Open "Schedule Task".

2. Create a new task. I put the following properties:

            * General:

                        - Name: At turn on (or whatever you want. This is just a name).

                        - When running the task, use the following user account: (here I put a user that belongs to the Administrators group).

                        - Run Whether the user is logged on or not, also checked "Do not store password"

            * Triggers: (here I put multiple triggers to make sure)

                        - At Startup

                        - At Logon: Any user

                        - On Connection To User Session: Connection from local computer

                        - On Disconnect from user session: Connection from Local Computer

                        - On Idle: repeat task every 1 hour for a duration of Indefinitely.

            * Actions: 

                        - Start a program: "C:\Windows32\reg.exe"

                        - Add argument: "reg add HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVerision\Authentication\LogonUI\UserSwitch /v Enabled /t REG_WORD /d 1 /f

            * Conditions: unchecked everything

            * Settings:

                        - only checked "Allow task to be run on demand" + "if the running task does not end when requested, force it to stop"

 

---------------------------

Now explanation:

As described here, there's seems to be a bug in Windows 8 LogonUI.exe process, and it automatically changes the registry key value from 1 to 0. As suggested in the link, one solution was to install a 3rd party program that will control it. However, I wanted to avoid installing 3rd party programs, and instead decided to use the Task Scheduler, which is already built in Windows systems, in order to automatically create and launch tasks.

 

The registry path above is the location of the LogonUI setting in the registry. The "reg add" in the beginning, simply adds the following path to the registry from the command line (you actually won't see that happening), and the /f switch forces it to overwrite the existing value.

 

After all that, I performed multiple restarts and shutdowns from all the users on my laptop, and seems to work fine.

 

By the way, I read somewhere, I don't remember where, that if you put passwords for users it also should work, but I didn't try it, because I don't want passwords.

 

Hope it will work for you. Let me know.

 

Sincerely,

Nativ.

 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

 
 

Question Info


Last updated March 24, 2018 Views 10,104 Applies to: