Foreign Keyboard on Start up

I am running Win 8 installed with en-US.  I have a French Keyboard on my laptop.

 

If I refresh,  change boot order with bitlocker or try to do  safe boot then the system assumes a US keyboard.  Once Windows starts all is OK.

 

The issue is that I have to remember the difference between AZERTY and QWERTY

On a US keyboard numbers are "1234567890" in French it is "&é"'(-è_çà "if you do not press shift.

 

This is a bit annoying if you have to put in your password or bitlocker key.  Note that once log-on screen is reached the keyboard is correct (French for me)

 

My system language is en-US.  Keyboard layout is French, Display Language is English (United Kingdom).

 

My question is when does the keyboard layout get loaded.  Is it possible to change it so in safe mode/Bitlocker recovery the correct keyboard layout is used? 

|

Is it possible to change it so in safe mode/Bitlocker recovery the correct keyboard layout is used? 


See if your other keyboard is listed and switched to by pressing Win-Spacebar.   Also, note that you could activate and use the On-Screen Keyboard via the Accessibility menu.   Doing that would at least guide you by seeing the correct keycaps.

1 person found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

On the recovery screen?  No you can not.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I have a similar issue. My Win 8 (x64 Pro) is in keyboard layout en-UK (default, no other languages installed), however when I start up the OS with BitLocker encryption, the keyboard layout is en-US (so to get the @ key I need to press Shift+2 which should be the " key).

Is it possible to change the pre-boot layout? I've checked the bios/UEFI FW settings but there's nothing in there for keyboards.

Machine: Lenovo Yoga 13, Win 8 Pro (x64).

Many Thanks,
Mike

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

when I start up the OS with BitLocker encryption, the keyboard layout is en-US (so to get the @ key I need to press Shift+2 which should be the " key).

Is it possible to change the pre-boot layout?


Doesn't look like it.   What about using a USB key instead?

 

http://technet.microsoft.com/en-us/library/ee449438(WS.10).aspx#BKMK_Key

(BING search for
    bitlocker keyboard
)

<quote>

We recommend that users set their keyboard layout to EN-US during enhanced PIN entry to avoid PIN entry failure in the pre-boot environment. If you are unable to enter an enhanced PIN from your keyboard even after setting the keyboard layout to EN-US, you must use a numeric-only PIN.
</quote>

 

BTW interesting that use of Function keys is preferred to numbers.  Who knew?   Thanks for making me find this.   ; )

 

 

Robert
---

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated March 24, 2022 Views 7,607 Applies to: