Windows Explorer doesn't show DLNA Server

I just setup a new Windows 8 VM, and I cannot seem to access a DLNA server from Windows Explorer.

It is accessible under Network Locations though:

If I start Windows Media Player I can see the Media Server. I can also see it as a Network Location.

 

But because it is not available under 'Computer', the Store apps are not detecting the Media Server. The same server is available under Computers from my Surface and the same store app is able to access the media server.

 

What am I missing?

 

I also have a nagging feeling that this happened after I setup Windows Media Player and that it was working before, but I can't say for sure.

 

Question Info


Last updated November 13, 2019 Views 8,842 Applies to:
Answer
Answer

Okay, solved it.

 

1. From the Charms Menu, click on Settings->Change PC Settings

2. In the Settings app, select Devices on the Left hand. It will list the Devices available on the right.

3. Here my device 'MediaPi' was shown offline. Select it, then I clicked on the (-) in the top to remove it.

4. Back in Windows Explorer, Select the Computer (on the left hand side).

5. From the Ribbon bar click on "Access Media"->"Connect to Media Server". It will take a while and should list your media server "MediaPi" in my case. Select it, and click Next.

6. Windows will show installing necessary files. Once it's done, you are done! Now you'll see the media server again.

 

8 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.