SOLVED - Xbox 360 System Music and Video Player app displays 'No Artists found' or 'No Albums found' messages when using shared media from a Windows 8 PC as the source.

Background Information

  • We have been using PC to Xbox media streaming for more than 5 years, previously with Zune software, and it always worked just fine.
  • The PC is a new computer running Windows 8 64bit Pro, which replaced a Windows XP system.
  • The "Play to" option worked just fine for us, only the Music\Video browsing a PC as a source was problematic. 
  • The Windows 8 PC and the Xbox 360 are on the same LAN (home wired network).


  • Make sure the Xbox is on while you are setting up the Windows 8 PC for sharing.
  • Make sure the Windows 8 PC can see the Xbox, goto PC Settings > Devices and you should see your Xbox listed, if not click add a device and it should be discovered.
  • Windows Firewall and Windows Defender do not have to be disabled, leave them on!
  • I did allow ICMP (ping) though the Windows Firewall on the PC beforehand, however I’m not sure if that is required for network sharing or not.
  •  If you aren’t an administrator you may be prompted to enter the administrator password for some steps (this is normal).
Troubleshooting Discoveries
  • A HomeGroup had to be enabled first; there are standard Control Panel options (search for HomeGroup) and settings in the metro UI under PC settings for HomeGroups. Oddly, both of those had to be configured. Also, be sure that 'Media Devices' is enabled in PC Settings > HomeGroup by using the slider to enable it.
  • After the HomeGroup is configured, from the Desktop > user folder, right click each folder you want to share (like your Music library) and share it to the HomeGroup. Use the same folder 'right click' to exclude folders from sharing if you wish to keep some things private.
  • File and Printer sharing needed to be on with the Network discovery option enabled (I think the system will ask if allowing Network discovery is okay, if so choose yes). You do this in the Control Panel > Network and Sharing Center > Advanced Sharing.
  • While you are in the Advanced Sharing area, enable the Media Streaming option located in the All Networks section and be sure to select the ‘Next’ button at the bottom when finished.
  •  Now open “Windows Media Player” and click the Stream options in the upper right tool bar area. Clicking 'more streaming options' will take you to the same Advanced Network sharing applet found in the Control Panel from the previous step. Here you can just double check the options you already selected. You can choose cancel if no changes are needed.

Question Info

Last updated April 7, 2019 Views 7,905 Applies to:

The step that actually fixed our problem

This last piece is the one that really fixed my wife's Win8 PC in the end. I happened to notice that the "Windows Media Player Network Sharing" service depended on HTTP and 'Windows Search' (Win7 only depends on HTTP). In the Control Panel I clicked Indexing Options, selected 'Modify', and then expanded the plus sign to manually add my wife's Music and Video folders. Those folders were not checked, so her media files were NOT indexed by default. After choosing those two folders and selecting OK, the files were indexed and media streaming worked from the Xbox using the system player app.

1 person was helped by this reply


Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.