Windows 8 Pro goes to Sleep after 60 seconds of inactivity

I just upgraded via clean install to Windows 8 Pro. Now the computer will go to sleep / standby after 60 seconds of inactivity. Interestingly, this behavior only occurs once the machine has already gone to sleep once in that power cycle. In other words, if I start from a cold boot, the machine will follow the power plan appropriately (screen saver after 10 minutes, sleep after 2 hours) until it has gone to sleep once, after which it will go to sleep every sixty seconds of inactivity. 

The system event log shows "Event 42 Kernel Power : The system is entering sleep. Sleep Reason: System Idle." But it does this after just one minute of idle. 

I have reset all power plans, I have created my own power plan. Hybrid sleep is disabled. I have run system file checker (sfc /scannow) and I have searched the forums extensively without an answer. 

This is a custom built desktop machine which never previously had this issue on Windows 7, it is a new behavior to windows 8.
Answer
Answer
So after a lot of digging and trying many things, the below solution worked for me. But if someone can verify this worked for them, that would be great:

It seems like maybe Windows is viewing the return from sleep as a remote wakeup which apparently times out to idle faster than other wake ups. To change this function, delete the following registry key: (maybe using the power button to return to sleep as suggested would be a work around?)

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\238C9FA8-0AAD-41ED-83F4-97BE242C8F20\7bc4a2f9-d8fc-4469-b07b-33eb785aaca0\DefaultPowerSchemeValues

To do this, Win Key + R (brings up the run menu), then type "regedit.exe" and navigate to the key location listed above. To be safe, you should save (export) that key before you delete it.

Alternatively, you could edit each of the sub-keys instead of deleting them. Each corresponds to one of the power plans. If you choose ACSettings you are choosing a behavior for when the machine is plugged in, DCSettings are for battery power. If you edit the key, switch do "decimal" The value listed is in seconds, and can be changed to any value you choose.

Please see this post for more information: http://social.technet.microsoft.com/Forums/da-DK/w7itprogeneral/thread/6909b30f-f71d-4dc6-9c42-12db1d38944f

13 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Answer
Answer

So after a lot of digging and trying many things, the below solution worked for me. But if someone can verify this worked for them, that would be great:

It seems like maybe Windows is viewing the return from sleep as a remote wakeup which apparently times out to idle faster than other wake ups. To change this function, delete the following registry key: (maybe using the power button to return to sleep as suggested would be a work around?)

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\238C9FA8-0AAD-41ED-83F4-97BE242C8F20\7bc4a2f9-d8fc-4469-b07b-33eb785aaca0\DefaultPowerSchemeValues

To do this, Win Key + R (brings up the run menu), then type "regedit.exe" and navigate to the key location listed above. To be safe, you should save (export) that key before you delete it.

Alternatively, you could edit each of the sub-keys instead of deleting them. Each corresponds to one of the power plans. If you choose ACSettings you are choosing a behavior for when the machine is plugged in, DCSettings are for battery power. If you edit the key, switch do "decimal" The value listed is in seconds, and can be changed to any value you choose.

Please see this post for more information: http://social.technet.microsoft.com/Forums/da-DK/w7itprogeneral/thread/6909b30f-f71d-4dc6-9c42-12db1d38944f

Hi, 

It worked for me, thank you!

had the same issue with Windows 10 (Built 10162) on my laptop. I have removed all the registry folders under the ...\DefaultPowerSchemeValues\.

After a reboot the issue has been  disappeared. 

6 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated August 9, 2020 Views 32,234 Applies to: