Windows 8 Metro Apps suddenly stopped working: Tried everything I can find nothing worked

I booted up my new Lenovo Ideapad Y480 with Windows 8 preinstalled for the first time on Thursday, I set everything up to my liking and had been using it without a hitch for about day until yesterday (Saturday) in the afternoon a bunch of the metro apps just suddenly stopped working (store, mail, skype, messenger, photo...etc) They would open up on a colored background sometimes showing the logo (often times the logo would be off in a corner) and a loading circle, sometimes just a solid color screen (I should add that the live tiles are still updating themselves even on the apps that don't open) I've been doing a lot of research and tried most of the common fixes with no avail.

I have:
1.Restarted computer (many many times)
2. Checked the resolution (1366x768)
3. Made sure UAC is turned on (although when I click on Change UAC settings it gives me a WerFault.exe-Application Error)
4. Created a Test user account
5. Reset IE as default browser
6. Clean booted
7. Uninstalled and Reinstalled my third party antivirus (AVG antivirus) and made sure it was updated
8. Checked for and installed all system and driver updates
9. Ran the App troubleshooter (It said said display adapter drivers might be out of date but the system said everything was up to date)

I can't uninstall and reinstall the apps because the store app itself doesn't work. And the only applications I was using at the time they all stopped working was Microsoft Word, Google Chrome and iTunes. And the only other thing I can think of is that I've been getting a WerFault.exe- Application Error on occasion since this all happened (sometimes on startup) that I'm not sure is related.

I think the only thing I haven't tried is refreshing or resetting Windows 8 which I really don't want to do... =/ Anyone have any more ideas?
 

Question Info


Last updated March 24, 2018 Views 4,660 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi Reighvan,

Thanks for posting in the Microsoft Community. Appreciate the detailed explanation of the issue you are facing. Sorry to know that it has caused so much inconvenience to you.

Method 1:

If there is an issue with Metro apps then the “app troubleshooter” would be the first troubleshooting which you have already tried. I would suggest that as mentioned by the troubleshooter you try and update the drivers for the Display adapters and check. Follow the steps to update drivers.

a) Move the mouse to bottom left corner and right-click on the ‘Start’ icon.

b) Select ‘device manager’.

c) Expand ‘Display adapter”, right-click on the adapter and select update ‘update driver software’

Method 2:

The werfault.exe is used for Windows Error Reporting. It is a feature that allows Microsoft to track and address errors relating to the operating system, Windows features, and applications. It gives you the option to send data about errors to Microsoft and to receive information about solutions.

Try the method provided and check.

a.       Press Windows+R.

b.      In the search bar type “services.msc” and press Enter.

c.       Scroll the list and right click on “Windows error reporting service”

d.      Choose Stop.

Check if the issue persists and let us know.

 

Vinod Archak
Forum Moderator

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I also got the device driver update, but still getting the same error after updating also. I refreshed my pc 2 times. They were working initially after both the refreshes but after few restarts they stop working.

 I also tried to change my user acc to local and again back to ms but after changing back to local it wont change back saying that it cant connect to its servers.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

hi Vinod Archak, 

Let you know that Problem found is "Display adapter might be out-of-date" is JUST AN BUG: False negative because there is WDDM 1.1 on Intel Series 4 Family Express including GMA 4500MHD, which is updated on March 2012 on my laptop., In fact, It's still "up to date", not outdated.   I prove that it works fine.   

Unfortunately, I'm very frustrated to fix XboxLive App after repeatedly crashing few sec for no reasons.   

Don't tell me sorry, but please reconsider carefully how to resolve issues If all other methods are failed. 

Lists of methods since I clicked Refresh once since two days ago: 

#1:
I switched to Local Account from MS Account & MSconfig: All applications including third-party softwares on Startup are disabled, except for MS programs, and unchecked Safe Boot   
#2 I ran SFC on Command Prompt with Admin. It showed "Windows REsource Protection did not find any integrity violations".  

#3 I updated all apps through Windows Store Setting. I also did wsreset.exe before XboxLiveApp still crashes after opening every times. 

All methods are unhelpful to fix Apps to prevent crashing. 

You know, I tried to uninstall XboxLive App via PowerShell, but I don't know well how to manage, it showed many invalid or errors, after I follow tutorial.  I did refresh once two days ago.  It's VERY UNHELPFUL. 

 As customer, we strongly recommend that MS Windows Team should creating App Tool Software which allows uninstalling or re-installing bulti-in apps such as Xbox, Store, etc.  You should talk with your MS colleagues about App Tool Software for ultimate solution instead of all failed methods.     

AppStore Troubleshooter need redo all bugs avoid false alerts such as outdated display adapter.    

Any final solution?????????????????????????

Thank you for understanding! 
Chris N

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I've tried both, still doesn't work

I think by now I've tried everything... I really can't believe it is that hard to make the thing work that made us upgrade in the first place. I've paid money to update from windows 7 to a worse version of windows 7

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hey buddy,
I faced same issue last week. But now everything is fine.
Do you have any anti virus software installed ?
 In my case issues were sorted out after formatting machine and installing windows without antivirus.

Try it. If you face the same issue again. Please let me know.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hey buddy,
Do you have any 3rd party anti virus software installed ?
If yes then Format your pc and reinstall windows.
This time do not install 3rd party antivirus.
use windows defender to protect your pc.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I've performed a System Refresh and it didn't help me at all.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Mr. Archak 
i have tried both the methods as mentioned by you..
when i ran the troubleshooter it said some files are missing or corrupt and it said the problem has been repaired..
i followed the other solution of stopping the windows error reporting service too and also all the methods as mentioned by the person who asked the question..
i would like to know what i can do and if there is any other solution..

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have same issue,  metro apps lose internet connection resulting in app errors as described above.  I tried to do a chat session with Microsoft support.. they wanted $99.00 to $149.00 for out of warranty service... I have owned software for 95 days.   Worked great for 91 days...then just lost interent connection to metro apps.  Now I have to pay for operating software again for only 30 day warranty...LOL you go microsoft.

 

I have refrehed 4 times...metro apps work until pc sleeps or hibernates, then when I wake it and relog on no internet for metro apps,  desktop works fine......That is not a user induced problem or driver problem..it is flaw in operating system inteligent plug and play or something...app troubleshooter is of no use.   says it finds stuff, but then fixes nothing,  tried all the setting fixes suggested...nothing bring metro apps back to life except refresh, but only until pc sleeps, hibernater or restarts.   Installing updates did not help either.   I have no software on PC excepts microsoft store game apps and skype for desk top...PC is my 4 year old son's for Disney, NICkJR, metro educational apps,   now he can not play several of his apps...Daddy fix it...fix it...fix it.....MICROSOFT LISTEN YOU HAVE A MAJOR FLAW...I geting a android tablet for him for apps and installing windows XP pro.  NO way paying for flawed operating system again, when i just spent $100 upgrading 95 days ago...Now spend 99 for 30 days support on $149.00 for 90 days....LOL  what a bargin,  I can go to walmart and buy another licence for 99 bucks gettin 90 days warranty....

 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Try resetting after backing up your files.  The apps probably have corrupted files in the AppData folder in your user account, and those do not get deleted in a refresh.  Also, if you had McAfee or Norton, these can cause this kind of problems, and you may not have fully uninstalled them.  You will need to run the MCPR Tool to remove McAfee products, and a different tool to remove Norton products.  Use these links to find the appropriate tool (they are located under the Remove [name] Automatically section an inch or two of scroll bar down the page):

 

McAfee: http://www.pchell.com/virus/uninstallmcafee.shtml

Norton: http://www.pchell.com/virus/uninstallnorton.shtml.

 

Hope this helps.

My Tech Blog: http://hosch250.wordpress.com/

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.