Windows 8 blurry/fuzzy text and icons on menu not on desktop

Hi

I upgraded from Windows 7 to Windows 8 Pro. The text and icons are a bit blurry/fuzzy/out of focus on the menu and in IE 10. It looks good on desktopmode. When I got Windows 7 the text and icons looked clearly. I tried to reinstall my Geforce driver and upgrade but the same problem. I see that many others got the same problem. How can I fix this? Otherwise I will install Windows 7 again. Thanks for helping me!!

Graphic: Nvidia Geforce 680
Processor: Intel i7
Windows 8 pro
16 GB RAM

 

Question Info


Last updated May 19, 2019 Views 24,987 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi,

 

 

Thank you for choosing Windows 8. As I understand, text and icons are a bit blurry and fuzzy on the start screen. I will surely help you to find a resolution regarding the issue.

 

Method 1:

 

Run the Play System maintenance troubleshooter and check.

Follow the steps to run the troubleshooter:

a.       Press Windows key + C on your keyboard to show the Charms bar.

b.      Type Troubleshooting and click Troubleshooting under Settings.

c.       Now type System maintenance in the search option.

d.      Click on Next to run the troubleshooter.

Method 2:

 

Try updating the graphics card drivers and check if it works.


 

Follow the steps to update the graphics card driver:


 

a. Press Windows key + X key and click on Device manager.


 

b. Search for Display Adapters.


 

c. Right-click on the graphics card and click on Update driver software.


 

Method 3: Uninstall and reinstall Graphics card:

uninstall the graphics card drivers and then try installing the drivers in Windows 7 compatibility mode and check if it helps.


 

Step 1: Uninstall the Graphics card driver from Device Manager.


 

Follow the steps to uninstall the Graphics card driver:


 

a. Press Windows Key + X and then click Device Manger.


 

b. Search for Display Adapter.


 

c. Right click the Nvidia Geforce 680 and click uninstall.


 

d. Follow the prompt and restart the computer.


Step 2: Install the driver in Windows 7 compatibility mode:

 

To install the Graphics card driver in Windows 7 compatibility mode, right-click on the setup file of the Graphics card driver and then click on ‘Troubleshoot Compatibility’ and select the Windows 7 compatibility mode.

 

Method 4: Clean boot

 

Perform a clean boot to check if any third party application is causing the issue, as clean boot helps in eliminating software conflicts. Follow these steps to start the computer in clean boot.

Step 1:

a) Press the ‘Windows + R’ key on the keyboard.

b) In the ‘Run’ windows type ’MSCONFIG’ and click ‘Ok’.

c) Click the ‘Boot’ tab and uncheck ‘Safe Boot’ option.

d) On the ‘General’ tab, click to select the option ‘Selective startup’, and then click to clear the option Load startup items check box.

e) On the ‘Services’ tab, click to select the ‘Hide all Microsoft services’ check box, and then click ‘Disable all’.

f) On the ‘Startup’ tab, click ‘Open Task Manager’. In the Task Manager window under startup tab, right click on each startup item which are enabled and select ‘Disable’.

g) Click ‘OK’, and then click Restart.


Step 2: Enable half of the services
a. Follow steps 1a and 1b to start the System Configuration utility.

b. Click the Services tab, and then click to select the Hide all Microsoft services check box.

c. Click to select half of the check boxes in the Service list.

d. Click OK, and then click Restart.
Step 3: Determine whether the problem returns
If the problem still occurs, repeat step 1 and step 2. In step 2, click to clear half of the check boxes that you originally selected in the Service list.
If the problem does not occur, repeat step 1 and step 2. In step 2, select only half of the remaining check boxes that are cleared in the Service list. Repeat these steps until you have selected all the check boxes.

If only one service is selected in the Service list, and you still experience the problem, the selected service causes the problem. Go to step 6. If no service causes this problem, go to step 4.
Step 4: Enable half of the Startup items
If no startup item causes this problem, a Microsoft service most likely causes the problem. To determine which Microsoft service may be causing the problem, repeat step 1 and step 2 without selecting the Hide all Microsoft services check box in either step.

Step 5: Determine whether the problem returns

If the problem still occurs, repeat step 1 and step 4. In step 4, click to clear half of the check boxes that you originally selected in the Startup Item list.

If the problem does not occur, repeat step 1 and step 4. In step 4, select only half of the remaining check boxes that are cleared in the Startup Item list. Repeat these steps until you have selected all the check boxes.

If only one startup item is selected in the Startup Item list, and you still experience the problem, the startup item that is selected in the list is the service that is causing the problem. Go to step 6.

If no startup item causes this problem, a Microsoft service most likely causes the problem. To determine which Microsoft service may be causing the problem, repeat step 1 and step 2 without selecting the Hide all Microsoft services check box in either step.

Step 6: Resolve the problem
After you determine the startup item or the service that causes the problem, contact the program manufacturer to determine whether the problem can be resolved. Or, run the System Configuration utility, and then click to clear the check box for the problem item.
Step 7:
Note: After you have finished troubleshooting, follow these steps to boot to normal startup.

a) Press the ‘Windows + R’ key on the keyboard.

b) In the ‘Run’ windows type ’MSCONFIG’ and click ‘Ok’.

c) On the ‘General’ tab, click the ‘Normal Startup’ option, and then click‘OK’.

d) When you are prompted to restart the computer, click ‘Restart’.

 

 

Hope this information helps. Please reply back with the status so that we could help you further.

 

 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thanks for your help!

I tried all above but I still got the fuzzy text and Icons in start menu.

 

The worst problem is in IE 10. The text is very blurry. I also tried to make a Clean install of Windows 8, change from DVI to HDMI and change to a different display.

I Think there is something with anti-aliasing or something. Because when I play games and when Im in desktop mode Everything looks good. The problem is only on the Win8 start menu and in IE 10 (and the apps).


When I go to desktop mode its crystal clear.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi. Here is what I have:

ASUS P9X79 LE, Socket-2011, KUN PC-PROD
Intel® Core i7-3820 Processor
Kingston DDR3 HyperX 1600MHz 16GB
Gainward GeForce GTX 680 2GB PhysX CUDA

 

I just upgraded the BIOS, chipset and the graphic card and Windows 8 update but I still got blurry text in all the Apps and the menu (Windows 8). When Im on the desktop Everything look crystal clear.


Whats wrong? Its a new computer and new OS.

Thanks

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I removed my NVidia drivers and that resolved the issue and reinstalling the drivers back on continued to allow my fonts to look clear.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I think I know the answer.

I installed Windows 8 on my other computer and it looked the same with blurry fonts in the menu but not on desktop. 

There is no cleartype in Windows 8 apps/menu but on the desktop it is. The fonts look very clear on the desktop.

I found this article: 
http://www.istartedsomething.com/20120303/cleartype-takes-a-back-seat-for-windows-8-metro/

Take a look at this:
http://imageshack.us/a/img210/7897/76061926.png (with IE10 on Windows 8)
http://imageshack.us/a/img405/6990/60450294.png (with Google Chrome on Windows 8)

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have virtually the same rig as OP.

Windows 7 was crystal clear and now looks dreadful in the "Modern" section of the OS, exactly as in OP.

Have tried all of MS recommended "cures" without success. I am so regretting having upgraded and feel MS could not care less.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

In order to attract Microsoft's attention, I've made a new post containing links to all previously posted threads about the same matter (blurriness - fuzziness  - bad font rendering in Windows 8).

 

If you would like to help, please click "Me too" for having the same problem on my post and/or other users' posts I've gathered all in one place. I have already clicked "Me too" on all posts that refer to the same matter.

 

Here is the link to my post:

 

http://answers.microsoft.com/en-us/windows/forum/windows_8-performance/poor-font-rendering-in-windows-8-blurry-text/f52a2002-d748-485c-8b9c-4862806ea94a?page=1

 

Thanks,

John

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

try this step. Go to control panel > display > adjust ClearType Text . Make Sure you turn on Clear type and just finish the wizard.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I FINALLY fixed mine by getting rid of HDMI and going back to DVI with a separate audio.  Hope that helps some of you...

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I FINALLY fixed mine by getting rid of HDMI and going back to DVI with a separate audio.  Hope that helps some of you...


Not going to work for me.

 

I am using dual link DVI anyway.

 

One can only hope an update or Windows Blue fixes this problem.

 

 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.