Question

Q: Safely remove hardware notification shows internal hard drives

My sata hard drives are shown in the "safely remove hardware" icon list and among "devices".

I would like them not to show in this list, as they are obviously not removable.

In Windows 7, I did a registry fix to solve this problem as here, second post down:

http://answers.microsoft.com/en-us/windows/forum/windows_7-hardware/my-internal-sata-device-appears-in-devices-and/722221d6-d59c-4cf7-803c-8203e6344b93

However, this does not work in Windows 8, as it seems the registry is different.

Is there a similar fix that works in Windows 8?


Hi,

 

Thank you for your post and giving us an opportunity to assist you.

 

I understand that the internal SATA drives show in the notification area when you go to remove an external drive safely.

 

What is the make and model of the computer?

 

You can try these methods to check if the issue gets resolved.

Method 1: Update BIOS.

Please contact the system manufacturer to update the BIOS.

Note:Modifying BIOS/ complementary metal oxide semiconductor (CMOS) settings incorrectly can cause serious problems that may prevent your computer from booting properly. Microsoft cannot guarantee that any problems resulting from the configuring of BIOS/CMOS settings can be solved. Modifications of the settings are at your own risk.

 

Method 2: Update chipset drivers.

Please visit the system manufacturers website and download and install the latest chipset drivers for Windows 8.

 

Feel free to use the forum for any other Windows questions you may have.

Did this solve your problem?

Sorry this didn't help.


Hi,

Thanks for the reply.

Yes, the internal SATA drives show all the time in the notification area to remove an external drive safely.

The computer is own built: motherboard Asus P5q Deluxe, cpu Intel Q9650, gpu GTX 470, ram G Skill 8Gb ddr2, hard drives, Intel 520 120Gb, Samsung 160Gb and Samsumg 320Gb.

I am using the latest BIOS update:

Brand    American Megatrends Inc.
Version    2301
Date    07/10/2009

As for chipset drivers, the latest offered by Asus are for Windows 7 64bit dated 2009. I tried to install these, but it said unsupported operating system. I also tried installing Intel Rapid Storage Technology, but this caused the system to hang on reboot.

So, I assume there is no solution to this problem in Windows 8?



Did this solve your problem?

Sorry this didn't help.


We need a fix for this problem from someone who knows the Windows 8 registry.

In Windows 7 it is possible to set the SATA channels to "Treat as Internal Port".

Surely this can be done in Windows 8 also?

Did this solve your problem?

Sorry this didn't help.


Microsoft needs to add an interface option to disable hot-plug per drive (someone log this request up the chain please).

 

Up until recently, installing Intel RST drivers made internal SATA hard drives register as fixed drives. Problem solved.

 

However, Intel have dropped support for older SATA controllers for Windows 8.1, which means that installing Intel RST may not be an option for many users (especially those with P5Q motherboards which have a controller that is no longer supported as of the latest driver pack). Apparently, Intel thinks the 8.0/8.1 transition is the ideal time to hit users for a motherboard upgrade, even though Microsoft intends it as a minor update!

 

Although Windows runs OK without the Intel drivers, there are problems:

 

  • Internal hard drives can only be protected with BitLocker to Go and cannot be automatically unlocked when the system boots. This is a big problem!
  • Windows Media Player displays some (smaller?) internal hard drives as portable music players for syncing. This can be disabled in Device Manager, so no problem.
  • It is all too easy to accidentally disable an internal hard drive while ejecting a USB thumb drive or similar. Irritating, but probably not fatal for most systems.

luceberg I do not know why your system could not take the Intel RST. Did you install the latest Intel Chipset INF pack first? It's a pre-requisite. Download them from Intel directly to get the latest version of the INF pack and the second latest version of RST (check the readme file to make sure your controller is covered).

 

At this time, I do not know if Intel's driver policy stands in the way of a successful upgrade to Windows 8.1. The actual controller driver for P5Q (in the Intel INF pack) is Windows 8.1 certified, but the RST package is not. It may still work, for all we know.

Did this solve your problem?

Sorry this didn't help.


Hi,

 

Actually, this is normal if your Bios is set for AHCI Mode for the SATA Drives and not IDE....

 

When in AHCI Mode, the drives are Hot-Swappable, and this makes it possible to "EJECT" them.

 

My machine is like this regardless as to whether I have Win 7 or 8 loaded....

 

The Reg Fix you mentioned is for an entirely different issue I think...

This has nothing to do with sata being confused with esata....

It is intentional for the purpose of hot-swapping drives...

 

It took me awhile to get used to it also....

Just Customize your Taskbar so that the icon isn't visible all of the time...

Did this solve your problem?

Sorry this didn't help.

1 person was helped by this reply


It is by design, but the "design" has issues in terms of practical use and bad consequences. Hiding the taskbar icon solves none of the problems mentioned above.

Did this solve your problem?

Sorry this didn't help.


Thank you very much, Paul.  I had not installed the correct Intel RST. Now I have done so, only removeable drives show up in "safely remove hardware".  Thanks again.

Did this solve your problem?

Sorry this didn't help.



  • Windows Media Player displays some (smaller?) internal hard drives as portable music players for syncing. This can be disabled in Device Manager, so no problem.

That's exactly what is annoying me. How do you stop Windows Media player treat hard drives as removable? Cause when i open it up it keep indexing all video/photo/audio files forever. You said this can be disabled in Device Manager.

I have 2 SATA internal hard drives connected and they show up in "Safely Remove Hardware and Eject Media". I accidentally ejected my second hard drive once or twice, instead of the USB flash drive. They run in AHCI mode, with the settings for SATA Ports 0-1 to run in Native IDE mode (instead of Legacy IDE).

I am running Windows 8.1 Pro on a Gigabyte GA-P35-DS3L with ICH9 SB chipset. I can't install and run any Intel Rapid Storage or Matrix Storage drivers.

I tried the Win 7 registry fix. MSAHCI is now STORAHCI but the TreatAsInternalPort registry value doesn't seem to work in Win 8.1. This is getting very annoying.

Did this solve your problem?

Sorry this didn't help.


There is no 'msahci' in Windows 8 so solution you mentioned wont work,  but there is another way, go to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\storahci\Parameters\Device look for value 'IgnoreHotPlug' open it and add hardware id for hard drive, for example:

Did this solve your problem?

Sorry this didn't help.

2 people were helped by this reply


 
Question Info

Views: 12,500 Last updated: July 10, 2018 Applies to: