Laptop overheats when plugged in but runs fine on battery...

I have a laptop that seems to overheat (to a point where it slows down and gets 'jumpy') but this only happens when it is PLUGGED IN. When I unplug it, the computer immediately speeds up (takes about 1 second for everything to run smooth again).

I understand that this is something to do with the way the laptop controls the cpu when it is on battery backup -but just wondering if anyone knows a good way to set it so that it uses the 'battery settings' while 'plugged in'. I tried changing the 'Maximum Processor State' under Power Options but it makes no difference...

I wonder if it might be the GPU that's causing the problem as it is during graphically intensive work (3D rendering, games etc) where I notice it most of all...

My laptop is a Samsung NP550 (NP550P5C-S02IN) running Windows 8 Pro.
|

Hi,

 

We would like to know the following detail from you so that we can assist you better.

 

Did you make any hardware or software changes to your computer prior to this issue?

 

Follow the troubleshooting methods given below to resolve the issue.

 

Method 1: Run the Power Troubleshooter.

 

You can run the Power troubleshooter to adjust your computer's power settings. The Power troubleshooter checks things like your computer's timeout settings, which determine how long the computer waits before turning off the monitor display or entering sleep mode. Adjusting these settings can help you conserve power and extend your computer's battery life.

 

After checking with the requirements, please perform power troubleshooter. Follow the steps given below:

 

a)        Press Windows + W together.

b)       Write Troubleshooting in the search box right up corner and hit enter.

c)        Click on Troubleshooting tab.

d)       Click on view all option on the upper left corner.

e)        Select the Power options from the list.

f)         Click Next to Run the Power Troubleshooter.

 

 

Method 2: Change the Power plan of your computer.

 

A power plan is a collection of hardware and system settings that manages how your computer uses and conserves power. Power plans can save energy, maximize system performance, or balance energy conservation with performance. The default power plans—Balanced and Power saver—meet most people's needs. But you can modify settings for existing plans or create your own plan.

 

Please follow the steps given below to change the power plans.

 

a)        Press Windows Key + X key together.

b)       Select Control Panel. Select Power Option.

c)        From the left hand side panel select Create a Power Plan.

 

You can refer to the following link.

 

Power plans: Frequently asked questions

 

http://windows.microsoft.com/is-is/windows-8/power-plans-faq

 

You can try to connect different cable to charge the battery.

 

Check for the status of the issue. Write to us if you still face any issues further.

61 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I kind of mentioned it in my post when I said "I tried changing the 'Maximum Processor State' under Power Options but it makes no difference..." but I already had tried changing around the power plans... etc.

I didn't get any help from the Power Troubleshooter either.

I did find a solution (work around) though, see post below...

7 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Solution Found! (Work Around)

Turns out the problem was my graphics card (GPU). It was just getting too hot (not as a result of the laptop being dirty or vents being blocked or anything like that). The issue was enviromental... I actually live in India and the weather here is very hot at the moment (over 48°C in my office!). I used my laptop in an air-conditioned room and everything worked fine.

note: A laptop cooling pad also made a difference (though only for about 20-30 minutes before it got too hot (and started to get jumpy).

...but as my office is not air-conditioned, this didn't help me. The 'work around' that I got to fix my problem was to disable the Geforce GPU and force the laptop to use its on board Intel Graphics Card.

I know this wont be a solution for everyone but it works for me -as I really don't need the additional benefits of the Geforce card...

14 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

That GeForce GPU normally isn't supposed to be running in anything besides programs that actually need a powerful GPU like games or 3D modelling tools
Seems like NVIDIA did a bad job on that Optimus technology
I face the same problem, I configured Chrome to use Integrated graphics but it still runs with NVIDIA graphics so I get absolutely NO benefits from having 2 GPUs

5 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I might have not made myself very clear (seems to be a regular problem for me). The problem really only happened in 'graphically heavy' work. Mostly 3D modelling & architectural programs where I noticed the lagging. :)

1 person found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Hi,

 

I would suggest you to uninstall the graphics driver and install it back form the manufacturer's website and check if it helps.

 

Please follow the steps given below to uninstall and then reinstall the driver.

 

a)        Press Windows key + X key when you are at desktop.

b)       Select Device Manager.

c)        Find and double-click Display Adapter from the left panel to uninstall

d)       Right-click the device, and click Uninstall.

e)        Windows will prompt you to confirm the device’s removal. Click OK to remove the driver.

 

After you have successfully uninstalled the driver, go to the manufacturer’s website and install the latest drivers for your computer.

Do let us know about the status of the issue.

10 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

This might be an old threat however it may help someone in the future as I had a similar issue.

So when ever my laptop was plugged in (Asus N52J) it would just start spinning up the GPU and heat up to about 70 degrees (mind you this is just running on idle with no software running).  As soon as you unplugged it, it would stop the heat and fans slowed down too.

So reading up on a few forums and one person mentioned going into NVIDIA control panel.

Theres no obvious settings to tinker with to ensure the GPU doesnt heatup whilst plugged in however if you click on Desktop tab --> Display GPU activity Icon in Notification Panel , you'll see the icon on the task bar.

This shows all programs using the GPU. Unplugged showed me no programs using the GPU BUT when I plugged it in , TA-DA a program called wabmig.exe pops up.

Googling showed me that this program is program is not necessary. Therefore I deleted it.

Within a few seconds.. laptop cooled down and heat gone!

13 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated May 1, 2021 Views 55,342 Applies to: