How to turn off DEP in w8 x64

Like the title says, i want to completely turn off DEP in w8 x64, any ideas

EDIT: I forgot to add that turning it off via cmd doesnt work(it says that value is protected and i cant change it, even if im running CMD as an admin)

Hi kelwinklayn,

 

From the issue description it seems that you are unable to turn off Data Execution Prevention (DEP) using command prompt. I do understand the inconvenience.

 

Data Execution Prevention (DEP) is a security feature that helps prevent damage from viruses and other security threats by monitoring your programs to make sure they use system memory safely.

 

If you choose to protect all programs, you can still turn off DEP for individual programs. If you suspect that a program does not run correctly when DEP is turned on, check for a DEP-compatible version of the program or an update from the software publisher before you change any DEP settings.

 

1)      Why do you want to turn off DEP?

2)      Are you experiencing any issues with any particular program?

 

There is no option to disable the DEP all together, If you are experiencing some issues with any particular program, you may turn off DEP for that particular program.

 

a)      Open System by clicking the Start button, clicking Control Panel, clicking System.

b)      Click Advanced System Settings.  If you are prompted for an administrator password or confirmation, type the password or provide confirmation.

c)       Under Performance, click Settings.

d)      Click the Data Execution Prevention tab, and then click Turn on DEP for all programs and services except those I select.

e)      Select the check box next to the program that you want to turn off DEP for, and then click OK.

f)       If the program is not in the list, click Add. Browse to the Program Files folder, find the executable file for the program (it will have an .exe file extension), and then click Open.

 

Hope it helps. For any further Windows related assistance, feel free to contact us and we will be glad to help.

 

Regards!

 

1 person found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

With all the respect Sir, your answer is wrong, and you should feel wrong.

You can completely shut down DEP in w8 x64, all you have to do is disable secure boot policy (http://www.youtube.com/watch?feature=player_embedded&v=ElzvaL96cw0) and then, command in CMD works.

4 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

You need to disable Secure Boot first, then you can use via CMD.

2 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

hice todo lo que dijiste y no me deja quitar el DEP del programa que quiero

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Agree with Mr. Azurdia, the answer above is not working, could´nt  disable DEP for IE

1 person found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Listen, you need to start system with advanced options (i dont know your motherboard, but its probably F10 button during turning it on) then you need to turn off Secure Boot. After your computer resets, you need to run CMD as administrator, and put command bcdedit.exe /set {current} nx AlwaysOff after that you need to restart your computer, and voilà, it works.

1 person found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

DEP is overly aggressive with online games and browsing while on IE 11 for 8.1 pro. forces constant crashes

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

OMG. DEP has wasted so much of my time!  I'm triangulating DNA analysis and my system is shutting windows down.  Thank God I now know how to fix this.  Thanks to all for posting - and no thanks to DEP.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

DEP is old hat to hackers and virus writers.  don't delude yourself that this system was bypassed years ago by these people.  second DEP  slows down your system almost crippling it, when you have a lot of installed stuff, or files. It was a good idea many years ago, before the hackers and virus writers came along, but this is the single worst offender at slowing down pc's and laptops.

As for the administrator control, again it's simply not needed and slows people down, and it no longer serves a genuine purpose.  You can simply bypass it if your a virus or malware / crapware creator.  

As for their being 'No way to disable DEP altogether", you are completely  wrong and i am growing tired of people passing misinformation either because they don't have a clue, or they have ulterior motives, quite why people would have ulterior motives about permanently disabling DEP is beyond me.  If you don't know, like you insinate from your above post, you should refrain from posting, this way people who do know, their answer is at the top of the list!

The question that was asked....how do i turn off / disable DEP?

For those on Windows 8, 8.1 and 10 YOU NEED TO TURN OFF SECURE BOOT OR YOU CANNOT TURN OFF DEP! 
once you have turned off DEP you can then turn Secure boot back on again and you will not have DEP

Be sure to disable the Secure Boot Policy 
Go to Settings / Computer Settings / General / Advance Start-Up's Restart Now / Troubleshoot / Advanced Options / UEFI Firmware Settings / Restart / Computer Setup / Security / Secure Boot Config / Accept / Secure Boot / *click to disable* / File / Save Changes & Exit

From Windows 7 onwards, all versions of windows use the same bcdedit codes

Open a command window under administrator:

then copy and paste the following:

bcdedit.exe /set nx optin
bcdeit.exe /set nx AlwaysOff

then restart your computer. problem resolved and windows 8 , 8.1 no longer runs DEP, note this will work for all versions of Windows 10.

4 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated August 12, 2020 Views 35,081 Applies to: