DVD autoplay is not working on Windows 8 computer

Normally, on data DVD insertion, a notification appears in the upper right and File Explorer, if open, is updated to show the DVD as D: in the left pane just under my local hard drive (C:).

After ~6-8 data DVD insertions (it varies), I insert the DVD and it "disappears".  No notification appears and File Explorer is not updated to show the DVD.  At first I thought this was a hardware problem.  MS tech support looked at this and couldn't figure anything out.

New info:  Once the DVD is inserted and nothing happens, if I go the "Computer" entry on the left of the File Explorer and then double-click the DVD drive in the right pane, bingo, the DVD information appears and the DVD is now shown as D: on the left pane of the File Explorer.

So, the question is, why does Windows 8 stop recognizing that a DVD was inserted?  AutoPlay stops running and File Explorer is no longer updated to show the DVD drive.

This happens on both my desktop (Puget Computer ASUS motherboard) and my laptop (HP dv7t-3000).

Note that I have to reboot in order for DVD insertion to work correctly again.

***Post moved by the moderator to the appropriate forum category.***

 

Question Info


Last updated December 15, 2018 Views 37,291 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi Yaamon,

 

Thank you for posting your query in Microsoft Community Forums!!

 

Based on the issue description I understand that Windows 8 cannot auto play any inserted DVD disc.

 

There are several reasons for this problem. AutoPlay might be restricted by Group Policy, it could be canceled by a program that is running, or the service that AutoPlay needs to start might not be running.

 

Here are some things to try:

 

Method 1

It's possible that AutoPlay has been turned off for those types of media or devices. To check this, follow these steps:

 

a)      Open AutoPlay by pressing winkey+X simultaneously, and then clicking Control Panel. In the search box, type autoplay, and then click AutoPlay.

b)      Make sure Use Autoplay for all media and devices is checked.    

 

Method 2

Follow these steps:

 

a)      Press winkey+Q button simultaneously, type CMD in search box, right-click Command Prompt, and then click Run as administrator. If you're prompted for an administrator password or confirmation, type the password or provide confirmation.

b)      At the command prompt, type net start shellhwdetection, and then press Enter.

c)      Restart your computer.

 

Hope it helps.

Keep us posted if you face any issues related to Windows in future. We will be glad to help you.

 

Regards,
Anil

6 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

"Use AutoPlay for all media and services" is indeed checked.

 

If you read my description carefully, you will see that AutoPlay does indeed work for the first 6-8 discs and then stops.   After 6-8 discs, AutoPlay does not respond AND FIleExplorer does not respond and update the left pane with the inserted DVD.

 

As I stated above, Windows 8 doesn't seem to realize that a disc was inserted.  This only happens after inserting 6-8 discs (it varies widely) and requires a reboot for Windows 8 to recognize disc insertion again.

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Anil, I had exactly the same problem.  However, after following all your instructions, the problem is not solved.  In particular, the CMD prompt won't accept 'Run as an administrator' as a command.

AutoPlay has simply taken a vacation!

I can solve the problem for playing DVDs, by first identifying and running the media player that runs the DVDs, before inserting the DVD, then it works fine. 

However, my Real need is that I have software in 4 CDs to install and I don't know which app to click that could bypass AutoPlay and run my software CDs. Therefore, please could you either, recommend which app to click, or, better still, suggest a solution to this AutoPlay bug. 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Meng Wen Ning,

 

1.       When you insert the software cd is it detected in computer?

2.       What happens when you try to access the CD?

 

Regards,
Anil

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,

 

I'm not sure if you are aware the Media Player in Win 8 won't play DVD disks of Files due to licensing issues. The only way to do this is by activating Media Center, or with a 3rd party player....

If you right click on the DVD and select "Open With", you can set a 3rd party player as the default player for DVDs

 

You can change your autoplay settings so that software CDs won't autoplay...

You can find Autoplay settings in Control Panel.

 

After disabling autoplay, just right click on the drive and select "Open" instead.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I'm having the same issue. Additionally, however, the files stored on the DVD are broken down into individual files - i.e. the media, instead of being a single compressed file, is dispersed into audio, video, and jacket folders which then contain files of select bits of the information. Is this an issue anyone else is encountering?

 

56 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I am putting memory cards in a card reader every day and it doesn't auto play anymore either.  What do they mean to press the winky key and a Q button. 

 

Bob

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,


Most newer keyboards have a "Windows" key at the bottom of the keyboard with a type of flag on it, next to the "Alt" key. This is sometimes called the winkey for short. It works like the Shift key or Alt key in that it changes the function of the next key you hit... Like the letter Q or X for instance...


You can also get to your Autoplay settings in Control Panel... Just right click on the "Start" on the lower left corner, and it will be in the menu.

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

What is winkey? explain!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

It is Windows Key + X. Reply with more information to help you better.

Regards,
Anil

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.