CPU doesn't drop below 30% in idle after update to 8.1

Hello,

I upgraded my OS to Windows 8.1 from Windows 8 from the store yesterday. Everything seems to be working fine - no lags or freezes, but I noticed that my PC doesn't drop below 30-35% in idle, also it doesn't downclock (balanced power settings) - it used to drop to 0.8ghz in idle and be like 1-4% in idle before the update, and now it's permanent 3.2ghz and over 30% in idle. I noticed that Service Host and System process in the task manager are draining over 10% CPU each, something that didn't happen before.

I know that this information is not very specific so I probably won't get solution to fix it, so I'm asking you for any advice how to get more specific information about the problem that's causing this CPU load. It will be best If there is someone with similiar problem to mine and has a working solution.

Thanks in advance!
 

Question Info


Last updated June 15, 2019 Views 6,045 Applies to:
This is my High CPU Usage log from Windows Performance Tool:
https://skydrive.live.com/redir?resid=BDA82663CC18E5B1!605

3 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I had the same problem a few weeks ago.  After digging around for several hours the problem was that Windows Backup (C:\Windows\System32\sdclt.exe) was being relaunched and immediately failing due to a DCOM permission error 67 times per second, maxing out the CPU on two or three cores.  My event log was full of errors like this:

 

--------

 The machine-default permission settings do not grant Local Activation permission for the COM Server application with CLSID 

  {C2F03A33-21F5-47FA-B4BB-156362A2F239}

   and APPID 

  {316CDED5-E4AE-4B15-9113-7055D84DCC97}

   to the user NT AUTHORITY\LOCAL SERVICE SID (S-1-5-19) from address LocalHost (Using LRPC) running in the application container Unavailable SID (Unavailable). This security permission can be modified using the Component Services administrative tool.

--------

 

If you look in Task Manager you will see the PID for sdclt.exe changing rapidly.  I don’t use Windows Backup anyway, so what I did to work around the problem until Microsoft fixes this rather epic bug is:

 

1. Reboot in Safe Mode so sdclt.exe won't be launched.

2. Take ownership of C:\Windows\System32\sdclt.exe and grant full control to the local administrators group.

3. Rename C:\Windows\System32\sdclt.exe C:\Windows\System32\sdclt.exe.no

4. Reboot.

5. Have a beer; you've earned it.

 

What makes this bug so nasty is that a few minutes after login it pegs 2-3 cores at 100% indefinitely without showing up in Task Manager, so it is very hard to track down: the offending process (sdclt.exe) launches and immediately exits only to be relaunched again immediately in an endless loop.   Renaming sdclt.exe is a hack, though, so if you need Windows Backup to work you could instead dig into granting the DCOM permission it is complaining about.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Instead of renaming the sdclt.exe try this:
- Go to Scheduled Tasks
- Microsoft -> Windows -> Windows Backup
- Disable the "ConfigNotification" Task (or anything you find here)

That should do the trick for the Windows Backup problem.

Also if the system log has a lot of DCOM errors it is possible to fix this. I dont have a link now but there is a example how to do it in some forum. Easy to find if you google for the CLSIDs.


Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thanks for the tip!  That's a more elegant workaround until the bug is fixed.  

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thanks for the tips! I already it fixed it with a stonecold disk format and fresh install :D

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.