Windows 8 Pro's Metro Apps can't connect to internet after first restart

Hello,

Recently I installed Windows 8 Pro x64 OEM, and I noticed after some  time that my Store, Weather, Stocks, News, ... can't connect to internet anymore. However, all other applications are working.
Even weirder, after installing all updates i noticed that i can browse with my IE on desktop, but not one started from metro?

Long story short, after several reinstalls ( refresh option) I noticed following behavior:

1. During first boot after install, EVERYTHING WORKS PERFECTLY. I can browse store, look at weather, everything.
2. When i restart computer, and every other time after that, is STOPS WORKING.

Another thing i noticed was that sound card (SoundBlaster Audigy) didn't work on first boot, but after restart it worked, so I guess that something happened after the first restart?

This was clean install (OEM version), and Windows are activated, and I tried signing in with and without live account (no difference).

Please help me, since this is quite irritating :(
 

Question Info


Last updated July 23, 2018 Views 5,667 Applies to:
Answer
Answer
Hello,

I finally found the issue.
The invisibility of active network pushed me towards the answer.

The biggest mistake I made was using the refresh windows option, because it was worthless for my troubleshooting.

By mistake I selected my connection to internet as public on first install, and during refreshing the system didn't ask me that again.
By setting the connection to private after clean install (no refresh, brute force reinstall) made everything work after reboot and completely solved the issue for me.



Why did the network disappear after reboot? This is something weird and it shouldn't happen !!!
The network troubleshooter found no problems, since connection to internet worked, but it also had no problem with no network showing up or metro apps not working.
This should be fixed, since it would be of great help in this scenario.


TL;DR : Make sure you set your connection to private, or windows goes crazy and your metro apps don't work (and i also noticed visual studio couldn't deploy projects in that scenario, but that is another story).

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.