Windows 8 Pro - Yahoo! Email - browser doesn’t support on IE 10

I received an error while login to Yahoo! using Microsoft Internet Explorer 10 of Windows 8 Pro x64:

 

"You're almost there, but your web browser doesn’t support the newest version of Yahoo! Mail"

 

For information, Windows 8 Pro already being updated to the latest via Windows Updates.

 

Please advise.

 

 

Question Info


Last updated March 24, 2018 Views 637 Applies to:

Hi Ricky,

 

Thank you for choosing Windows 8. I will definitely try and help you and make you Windows 8 experience a great one.

 

To help you suggest steps to resolve the issue, I would appreciate if you could answer the following questions:

 

1.       Are you using the desktop version or the modern Internet Explorer to visit the WebPages?

2.       Is the issue specific to this particular websites or all the websites?

3.       Do you have any third party security program installed in the computer?

4.       Are you aware of any recent software or hardware changes in the computer?

 

If you are using the desktop version to visit the website, try it in no add on mode and check.

 

Internet Explorer no add-ons mode.

 

 a.       Press the Windows Key and the R key simultaneously to get the Run prompt.

 b.      In the Run prompt, type iexplore  -extoff and press enter.

 c.       This will open Internet Explorer in no add-ons mode.

 Open the website and check if you are able to access it without any issues.

If the issue persists you may reset Internet Explorer and check if it helps.

Note: Close all Internet Explorer Windows when performing Reset.

a.       Press the Windows key and the R key together to get the Run prompt.

b.      In the Run prompt, type inetcpl.cpl and press enter.

c.       Click on the Advanced tab.

d.      Select Reset to reset Internet Explorer settings.

 

Internet Explorer Disclaimer: The Reset Internet Explorer Settings feature might reset security settings or privacy settings that you added to the list of Trusted Sites. The Reset Internet Explorer Settings feature might also reset parental control settings. We recommend that you note these sites before you use the Reset Internet Explorer Settings feature.

 

You may also contact Yahoo support for any known issues.

 

Hope this helps and provide us with more information if you need further assistance. We will be glad to help.

Rohit Chettri
Forum Moderator

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have tried the methods you provided, the result still the same.

 

Funny thing is, I have another desktop PC with Win8 Pro x64 IE 10 accessing new Yahoo! mail without any error.

 

Please advise.

 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have another desktop PC with Win8 Pro x64 IE 10 accessing new Yahoo! mail without any error. 


Most likely this is a User-Agent problem.   One way to compare them would be via the Developer Tools, Console tab.   In the Command line there enter:  navigator.userAgent

BTW note the capitalization of the Property name.


You could also compare them using the Developer Tools, Network Capture  (F12, Ctrl-Backtab, F5)

 

 
---

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I went through installation for the second, third time. From the process, initially Windows 8 Pro x64 IE 10 able to login into new Yeahoo! page with no problem.

 

Later, after installed other browsers like Chrome, Opera, Firefox, Safari the issues occurred. I am sure this is caused by third parties software installation that related to plugins or some system .DLL is overrided if not mistaken.

 

 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I found the solution, using IE10, click the "Compatibility View" several times then followed by

clicking the "Refresh" button.

 

This you will noticed at lower text message "Continue, anyway" from the Yahoo! site.

Click on this link, and you will enter into the latest Yahoo! mail environment.

 

Most likely this is Yahoo! own issues not IE10.

 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.