Windows 8 Pro Unidentified network


I have a Windows 8 Pro 64 bit bit computer and it says my wifi internet connection is "Unidentified-No network access". 

I have a WiFi hotspot and it works on my Dad's PC and my Android tablet. (by the way, the hotspot is a public network with a p/w)

I have tried:

Rebooting PC and Router,

Windows troubleshooting (shows "WiFi does not have a valid IP config")


Have turned off Windows firewall (witch worked for 10 minutes) and I have uninstalled Quicktime & Bonjour,

I have no strange services running in the background in taskmanager


Unticked TCP/IPv6

Disabling/Enabling WiFi adapter

Uninstalling WiFi Adapter driver.


Deleted ROUTE

"Forgetting" the network

Re-installing IPv4 & Ipv6


I ran as admin these commands

Reset WINSOCK entries to installation defaults: netsh winsock reset catalog

Reset IPv4 TCP/IP stack to installation defaults. netsh int ipv4 reset reset.log

Reset IPv6 TCP/IP stack to installation defaults. netsh int ipv6 reset reset.log


netsh int ip reset C:\netsh.log.txt
netsh winsock reset

All don't work. I have noticed one wierd thing. In the wireless adapter properties TCP/IPv6 & TCP/Ipv4 have "uninstall" whited out. 

I have tried re-installing them but that didn't work.

The last program I have installed is Adobe Download Assistant (I have uninstalled it, didn't work)

And the last Windows update installed was a "Critical update for Windows 8. But it didn't place a restore point before install.

Any help would be appreciated.


PS: I contacted my internet provider and they said: "It is not our fault, contact your PC manufacturer". I did, but he couldn't figure it our either.




There is a APIPA address assigned automatically to the Wireless Adapter and as a result of which you are unable to join any network or access Internet.


APIPA - Automatic Private IP Addressing




APIPA is a DHCP (Dynamic Host Configuration protocol) failover mechanism for local networks. With APIPA, DHCP clients can obtain IP addresses when DHCP servers are non-functional. APIPA exists in all modern versions of Windows.

When a DHCP server fails, APIPA allocates IP addresses in the private range to Clients verify their address is unique on the network using ARP  (Address resolution Protocol). When the DHCP server is again able to service requests, clients update their addresses automatically.


In APIPA, all devices use the default network mask and all reside on the same



I would have you try these command once again.


netsh int ip reset resetlog.txt
netsh winsock reset
ipconfig /registerdns
ipconfig /flushdns
ipconfig /release


Restart the computer and then check if you are able to connect to the network.


If the issue persists, manually assign a IP address for the Wireless network and then try to ping the Router to check if there is proper connection.


- Press Windows key and the R key and type NCPA.CPL

- Right click on the Wireless network that you use and select Properties.

- Highlight or select Internet Protocol version 4 and click on Properties.

- Select Use the Following IP address.


If the Router IP address is and the other computer IP address is in the same sequence, then try to assign and the subnet mass and press enter.

- Close the Network properties window.


- Open the Command Prompt and type ping and press enter.

- Type ping and press enter

- Type ping and press enter.


Let us know if the packets sent are equal to the packets received.


Post a screenshot after doing so.





Microsoft Desktop Support Engineer

1 person found this reply helpful


Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.


Question Info

Last updated October 6, 2020 Views 14,191 Applies to: