Windows 8 Firewall is preventing me from using the local network

Hey all,

 

Sometime in the last week, Windows Firewall started blocking me from using my home network. I can access the internet fine, but I can't access any other computers or printers on the network.

Just FYI, I use only Windows Firewall / Windows Defender (no 3rd party security software)
If I try to browse the network, I see this message:
Network discovery and file sharing are turned off. Network computers and devices are not visible. Click to change...
When I do that, if I click on Turn on Network Discovery and File Sharing, the error message immediately returns. I can't turn on Network Discovery or File Sharing manually, either.
In Services, Computer Browser is off. I can start it, but then if I refresh the Services list, it's off again.
Now, if I turn off Windows Firewall, Computer Browser starts automatically and I can access the network just fine. While Windows Firewall is off, if I click Use recommended settings, Windows Firewall turns itself back on and, again, I can't do anything on the local network.
(and let me re-iterate, all network stuff was working fine last week...browsing computers, printing to network computers, etc.)
I've also tried the Restore Defaults link in Windows Firewall and after doing that, nothing improves. Still cannot do anything on the network with Windows Firewall turned on.
The only things I've installed in the last week are Defiance (through Steam) and the Neverwinter client.
Anybody else having this issue? I've seen lots of references to similar problems online, but none of the resolutions I've found have worked in my case.
Any help would be appreciated. Since Win 8 only has 90 days free support (!?!?!?!!?!) I'm SOL from Microsoft unless I want to pay $150 for support for a year.
Thanks
L
|

Hi,

 

This might be happen when few applications and Windows Features are blocked by the Windows Firewall.

 

I would suggest you to allow an App or Windows Features through the Windows Firewall and check if this fixes the issue.

 

Refer to the step “Allow an app to receive info through the firewall” from the link “Windows Firewall from start to finish” to know how to allow an app or features through Windows Firewall.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Sathish, thank you, I understand what a firewall is and what it does, however, the basic concept of firewall usage doesn't solve this problem, because it's the network itself that isn't being allowed through the firewall.

 

There are no specific rules blocking it.

 

It simply has stopped working in the last week or so.

 

I uninstalled both Defiance and Neverwinter to see if that would help, but it hasn't.

 

And in fact there were 4 inbound rules added for Neverwinter that still remained even after I uninstalled the software and even after using the Restore Defaults feature in Windows Firewall (so, I'm not sure what Restore Defaults does if it doesn't complete reset Windows Firewall to its original "factory" settings).

 

Of course I removed those rules but still no joy.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

How strange, I've the same issue and the same time frame. To start with the Firewall wouldn't turn on, but after updating Windows, it started working again, but now that its back up, I can't turn on my network. If I go into the setting and turn on network discovery, and save, when I return to check them, they have changed back to off.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Hi,

 

I would suggest you to place the computer in clean boot state and check how it works.

You can start Windows by using a minimal set of drivers and startup programs. This kind of startup is known as a "clean boot." A clean boot helps eliminate software conflicts.

To set the computer in clean boot, follow the steps from the link: How to perform a clean boot

Note: After checking in clean boot, follow the step “How to reset the computer to start as usual after clean boot troubleshooting” from the article to reset the computer to normal boot.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

only thing changed before homegroup fail was windows 8 updates installed. YOU CAN NOT turn off windows firewall on private networks, only PUBLIC, that's reverse of what it should be.. #1 clue something wrong. Disabling windows firewall in services fixes the homegroup issue instantly... AND by the way, you CAN NOT select a "service" only an app in rules, so no way to fix this bug till MS puts it in as an option. This not the first time, MS had this issue with windows 98, why we had to buy windows 98 SE (second edition). I'm about to throw win 8 away and reinstall windows 7 again.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated March 24, 2018 Views 558 Applies to: