WI-FI connection repeatedly goes"Limited" on Windows 8 Tablet

I bought  an Acer Iconia W700 and upon using Wi-Fi i noticed that my connection kept getting interrupted. It says i have  "Limited" connectivity. I thought it was a temporary server or router problem,  but upon further observation ( with my Ipad on the same network) i found out it was only the Iconia who is exhibiting the problem. I complained and had the unit replaced after a day but sadly, the new replacement is having the same problem.  
 

Question Info


Last updated March 16, 2020 Views 26,973 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

I have the same problem with my Acer Iconia w700.

I have a D-link 655 router.

I have a win xp laptop, a HP stationeary with Win 7, a HTC with android and all of them work fine on my wifi. But the Iconia gets limited connectivity all the time, and some time it does not find any wifi at all.

Ive alos updated the router sw.

Any tips?

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have the same problem. I even reinstalled it twice and still the same "limited connectivity" problem. Perhaps we should wait for the latest drivers to be released?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I solved it by doing some changes on my nettwork setup.

Ive set my ISP router in DMZ mode. (forward everything to my Dlink router). This has been working fine with xp, win7, android but it looks like it is making trouble for windows 8.

So i tried to enable WIFI on my isp router and its been working fine for a day now.


Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Found an alternative solution as well.

Open network and sharing  > change adapter settings > wifi adaptor properties > configure > power management > uncheck "allow the computer to turn off this device to save power"

 then go to your battery settings

Battery icon > more power options > power saving / balanced / high performance > change plan settings > change advanced power settings > wireless adaptor settings  > power saving mode  > on battery >  change to low or medium power saving (although troubleshoot says medium power saving should fix the problem, I chose the low power saving, so far no hiccups with the "limited" connectivity.)

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I solved it by doing some changes on my nettwork setup.

Ive set my ISP router in DMZ mode. (forward everything to my Dlink router). This has been working fine with xp, win7, android but it looks like it is making trouble for windows 8.

So i tried to enable WIFI on my isp router and its been working fine for a day now.


Hi there,

Could you provide more details?
I also have Windows 8 Pro PC (among other devices) which sharing the same WIFI network and does not have any issue. So, I doubt, Windows 8 is the issue here.

Limited connection issue with my Acer W700 is really annoying.

Thanks.
Sharing is a must

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Found an alternative solution as well.

Open network and sharing  > change adapter settings > wifi adaptor properties > configure > power management > uncheck "allow the computer to turn off this device to save power"

 then go to your battery settings

Battery icon > more power options > power saving / balanced / high performance > change plan settings > change advanced power settings > wireless adaptor settings  > power saving mode  > on battery >  change to low or medium power saving (although troubleshoot says medium power saving should fix the problem, I chose the low power saving, so far no hiccups with the "limited" connectivity.)


I tired your suggestion and didn't work for me.
Are you using it with the dock + power plugin or running it on the battery?

Sharing is a must

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

i finally got it working. i tried the other methods as well but still had the problem. i went to acer and downloaded the wifi drivers, uninstalled the device in device manger, restart pc, went back to device mmanager and looked for the unknown device. i then right click unknown device and installed the driver from acer.

 

it has been 3 days with no disconnect or limited status. also, the wifi now autoconnects if u tick the box to autoconnect. previously i still had to connect manually.

 

it seems to be much more stable now.

 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

i finally got it working. i tried the other methods as well but still had the problem. i went to acer and downloaded the wifi drivers, uninstalled the device in device manger, restart pc, went back to device mmanager and looked for the unknown device. i then right click unknown device and installed the driver from acer.

 

it has been 3 days with no disconnect or limited status. also, the wifi now autoconnects if u tick the box to autoconnect. previously i still had to connect manually.

 

it seems to be much more stable now.

 

Thanks for the update. 
I noticed Acer just released a driver 2 days ago.
I hope, it will fix the issue.

For download: HERE


Edit: 224 MB for a wifi driver..????
Sharing is a must

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

ive tried this new driver...but it doesn't work...however i think it happens less often than before,but it still happens...so sad

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

ive tried this new driver...but it doesn't work...however i think it happens less often than before,but it still happens...so sad


Yah... It's a sad case. I will call Acer tomorrow. I'm from Singapore.
Sharing is a must

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.