Unable to stay connected to the internet

I just bought a brand new Dell laptop (Inspiron 3520) with Windows 8 and it won't stay connected to the internet. It will be fine, but then after a while it will stop connecting and I have to reconnect. When it does this, sometimes it will say "limited connectivity" but usually it appears normal, even when I go in and disconnect and reconnect; usually the only reason I know there's a problem is because nothing will load. After I reconnect, everything resumes as normal until it disconnects again.

This has happened in multiple places with multiple connections, while devices such as my iPhone have had no trouble with the same connections. When I briefly connected to the modem with a cable it worked just fine.

edit: I've tried troubleshooting through Windows and updating drivers and none of that has been successful.
 

Question Info


Last updated September 10, 2018 Views 6,737 Applies to:
Updating the BIOS from Dell fixed the problem for me.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I had the same problem, could connect to the internet with an Ethernet cable but would get booted off wireless. The fix came with my wireless router settings.  I updated the firmware on my Netgear router, changed from WEP security to WPA2-PSK AES and this resolved my issue. I also set the wireless channel to 11 based on a post recommendation. Hope this helps.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,

We are glad to assist you with the issue that you are being disconnected from the wireless connection. I know the issue can be annoying. We will work together and find a resolution for the issue. We need some more information to assist you.

1.      What are the troubleshooting steps you have tried?

2.      What is the model of the computer you are using?

3.      Which anti-virus software is installed on the computer?

4.      Did you make any recent changes to internet settings?

 

 

Here are few methods we can try as of now to check if this helps in resolving the issue.

 

 

Method 1: Run Internet Explorer Connection troubleshooter.

a.       Press the ‘Windows + W’ key on the keyboard.

b.      Type troubleshooter in the search box and then press ENTER.

c.       Select Troubleshooting. Click on view all and select Internet Connections.

d.      Click next and follow the on-screen instructions.

 

 

 

Method 2: Uncheck "Allow the computer to turn off this device to save power

a.       Press Windows key +X.

b.      Click on Device Manager.

c.       Right click on Network adapter.

d.      Click Properties.

e.       Click on Power management tab.

f.      Uncheck "Allow the computer to turn off this device to save power".

g.       Click Ok.

 

 

Method 3: Please refer the links for more troubleshooting steps.

http://windows.microsoft.com/en-IN/windows/network-connection-problem-help#network-problems=windows-8&v1h=win8tab3&v2h=win7tab1&v3h=winvistatab1&v4h=winxptab1

http://windows.microsoft.com/en-US/windows-8/cant-connect-to-internet

 

Hope this helps. Please keep us posted. Get back to us if you have any more questions.

 

Niyamath H Mohammed
Microsoft Community.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I had the same problem, could connect to the internet with an Ethernet cable but would get booted off wireless. The fix came with my wireless router settings.  I updated the firmware on my Netgear router, changed from WEP security to WPA2-PSK AES and this resolved my issue. I also set the wireless channel to 11 based on a post recommendation. Hope this helps.

Thank you so much! This seems to have done the trick!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Stop everybody. Don't listen to these scientific answers. I suffered for a year and found it. Go into settings system and security and power settings and make sue you indicate the PC to never go to sleep. That fixes this problem.settings

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

1. I tried the troubleshooting steps you suggested, other troubleshooters on my laptop (there have been a few, I can't remember specifically which ones), I have tried preventing my laptop from automatically connecting to a connection, and I have reset the modem several times.

2. My laptop model is listed in the question.

3. I have McAfee Total Protection.

4. The ONLY changes to my internet connection have been made in an attempt to fix this problem. I have had a problem with this since I first used this laptop (it is brand new, not refurbished).

Unchecking "Allow the computer to turn off this device to save power" did not work.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Did that and still getting the same stuff. I think I will try that scientific stuff out.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.