Remote desktop connection drops repeatedly after upgrading to Windows 8, making it impossible to remote into my work desktop for more than 20 seconds at a time

After upgrading to Windows 8 in October, my remote desktop connection to my work computer (running on Windows XP) has become completely useless, dropping every 20-30 seconds for the entirety of its use.  It is become literally impossible for me to remote into my work desktop which is essential as I work Asia hours and travel frequently, forcing me to frequently work remotely.  I have troubleshooted everything, including my work desktop, my work's network connection, Juniper Terminal Services which is the program used, without finding a solution.  After talking to many tech experts and doing many google searches on the issue, it has become clear that problem is most definitely the Windows 8 operating system.  Many other people are having exactly the same issue, all after upgrading to Windows 8.  Make no mistake, this is a Windows 8 issue and Microsoft needs to provide a fix ASAP as millions of people all around the world require the ability to use remote desktop tools everyday to work, and the Windows 8 operating system is inadequate for this purpose in its current state.  

Please provide a solution ASAP.
 

Question Info


Last updated July 15, 2018 Views 6,062 Applies to:

Hi Christine,

 

Thank you for posting your question on Microsoft Community Forums.

 

Based on the description I understand that you lose Remote desktop connection after every 20seconds as you try to connect from Windows 8 to Windows xp.

 

To help you better please provided answer to these questions:

1.      Are you using a wired or wireless connection?

2.      What troubleshooting have you tried?

3.      Have you made any changes on the computer prior to the issue?

I would suggest you to follow the methods provided to fix the issue.

 

 

Method 1: Start the computer in clean boot to check if any third party program is causing the issue. To configure your computer to clean boot refer the following link.

 

http://support.microsoft.com/kb/929135

Note: After performing the troubleshooting steps in clean boot, follow Step 3 from the link to start the computer to Normal start up mode.

 

 

 

Method 2:

Disable the security software temporarily and check if it helps.

Note: Antivirus software can help protect the computer against viruses and other security threats. In most cases, you should not disable the antivirus software. If you do have to temporarily disable it to install other software, you should re-enable it as soon as you're done. If you are connected to the Internet or a network during the time the antivirus software is disabled, your computer is vulnerable to attacks.

 

 

Method 3: Run the Network troubleshooter

Follow the steps to run the troubleshooter:
a. Open Search by swiping in from the right edge of the screen (or if you're using a mouse, pointing to the upper-right corner of the screen and moving the mouse pointer down), and then tapping or clicking Search.
b. Type Troubleshooting and click Troubleshooting under Settings.
c. Now type Network Troubleshooter in the search option.
d. Click on Network troubleshooter to run the troubleshooter.

 

 

Kindly get back to us with the more information so t hat we can assist you better.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Vikrant,

Even I am facing the same issue. I have followed all the trouble shooting steps. But still the issue persists. I am using a wireless network connection.

Please provide a solution ASAP.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I came here looking for issues similar to mine. While it's not dropping the connection, the performance on Win8 Pro's remote desktop connection is very poor. It worked fine before on the same machine with Win7. I gave up and remoted in with the Surface RT and that works perfectly fine. Seomthing about Win8 Pro just isn't right when it comes to remote desktop. :-/

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

In an interesting turn of events, I installed the optional update,
Marvell - LAN - Marvell Yukon 88E8040 PCI-E Fast Ethernet Controller,
this morning and tried the remote desktop again to much better success than previous days. I didn't interpret it to be related to the remote desktop issue and if anything, could be specific to my machine, but it was a pleasant surprise that didn't seem too coincidental considering the performance was consistently poor before and has been consistently okay since the update.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Vikrant,

Even I am facing the same issue. I have followed all the trouble shooting steps. But still the issue persists. I am using a wireless network connection.

Please provide a solution ASAP.

The following solution helped my case.  I got the solution from below forum.
http://kevinmarquette.blogspot.com/2012/10/windows-8-and-juniper-rdp-vpn.html


Go to Group Policy:
Local Computer Policy --> Computer Configuration --> Administrative Templates --> Windows Components --> Remote Desktop Services--> Remote Desktop Connection Client -->
Turn Off UDP On Client --> set the value to Enabled

Modify the below Regedit:

HKLM\SOFTWARE\Policies\Microsoft\Windows NT\Terminal Services\Client\

Create a dword and assign a value of 1 to:  tofClientDisableUDP dword:00000001

 

How to Start the Group Policy Editor
To start the group policy editor, follow these steps.

NOTE: You must be logged on to the computer using an account that has administrator privileges in order to use Group Policy Editor. 1.Click Start, and then click Run.
2.In the Open box, type mmc, and then click OK.
3.On the File menu, click Add/Remove Snap-in.
4.Click Add.
5.Under Available Stand-alone Snap-ins, click Group Policy, and then click Add.
6.If you do not want to edit the Local Computer policy, click Browse to locate the group policy object that you want. Supply your user name and password if prompted, and then when you return to the Select Group Policy Object dialog box, click Finish.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Regarding the above recommendation of:

Modify the below Regedit:

HKLM\SOFTWARE\Policies\Microsoft\Windows NT\Terminal Services\Client\

Create a dword and assign a value of 1 to:  tofClientDisableUDP dword:00000001


This is not the correct setting. It should be fClientDisableUDP dword:00000001

No "to".

But sorry to say that did not work for me. Neither did-
-removing my Cannon Scanner driver
-removing my wireless printer driver
-turning off the printer spooler
-setting compatibility to W7 and XP-S3
-waving a dead chicken around in the air.

I really hope someone comes up with something that really works.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I'm a remote worker and can no longer work for more than 20 seconds.  Doesn't Microsoft have a solid plan for this problem that can be shared, or do you only have a bunch of "troubleshooting" tips that provide no help, as usual?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I finally found a way around this, at least for Juniper, which is probably where you are having the problems. Use the Juniper "Network Connect", and then RDP in from there. You may need help from your admin person, but it now works for me in W8.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.