Network driver does not start after sleep mode, Windows 8 Pro 64-Bit

I recently upgraded to Windows 8 Pro 64-bit from Windows 7 Ultimate 64-bit. I have a custom build computer using an Asus Sabertooth P67 B3 with an Intel I7. However after the upgrade to Windows 8, every time I put my computer to sleep, and I wake it up, I have no internet connection. If you look in the device manager I get the "This device cannot start" (code 10) error. I have to right click on the driver and go to search for hardware changes, and this will fix the issue. Expect it is annoying to have to do this every single time. So I have tried upgrading to the new version 12.2.4.45.0 of the Intel(R) 82579V Gigabit Network Connection driver, I then went into the driver properties and into the power management tab and made sure that energy efficient ethernet was not checked. However the problem persist. Any help would be greatly appreciated, thanks 
 

Question Info


Last updated November 11, 2019 Views 12,317 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi Darker Knight,

Thank you for posting in Microsoft Community.

I understand that you are facing the issue with Network driver does not start after sleep mode and receive “This device cannot start" (code 10) error”,

The Code 10 error pertains mainly to hardware and device driver issues or to compatibility issues between hardware drivers and additional software that is installed in Windows.

1.      Go to device manager by press windows key + R, and type in devmgmt.msc and click enter.

2.      Right click on network adapter and select Properties

3.      Go to Power Management tab and uncheck the box to allow the computer to turn off this device to save power.

I would suggest you to refer the links and check.

Wired and wireless network problems

http://windows.microsoft.com/en-us/windows/network-connection-problem-help#network-problems=windows-8&v1h=win8tab1&v2h=win7tab1&v3h=winvistatab1&v4h=winxptab1

Also refer:

Why can’t I connect to a network?

http://windows.microsoft.com/en-US/windows-8/cant-connect-to-a-network

Why can't I connect to the Internet?

http://windows.microsoft.com/en-us/windows-8/cant-connect-to-internet

Please perform these recommended steps, review the additional information provided and post back if you are still experience the issue. I will be glad to provide you with additional options available that you can utilize to get this resolved.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I am having the same problem also. I have changed Power Management to not put net to sleep. This worked at first but it no longer solves the problem of waking net from sleep mode. I have updated drivers from Intel's web site to win 8, but this does not solve problem. Any help would be appreciated

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I already did what you suggested and it still happens after wake, now however I have a different issue. 
Since there was no solution to my previous problem, I would wake up my desktop go to device manager, scan for hardware changes and it would come back on.I kept doing that for days.
Now my pc shows its connected the driver says its working fine, but I have no internet access with any program. Itunes, Steam, Mail, Chrome, IE, anything. And my Mac's and HP desktop connect to the internet just fine. 
I have 
1. uninstalled and reinstalled the driver.
2. I have deleted the driver, downloaded the driver to a flash drive from my other PC and installed with no luck.
3. I have turned on and off the firewall.
4. disabled my AV software.
5. Tried the trouble shooter, and it says it can't identify the problem.
6. I disabled the windows debug under network adapters
7. Made sure IE is set to automatically detect, under connection settings
8. Ran ipconfig /all
9. Ran ping 4.2.2.4
10. Ran ping 127.0.0.1 

I am really hoping I don't have to reinstall windows 8 and then have to reinstall all my programs, because if thats the case I am going back to windows

Any help would be greatly appreciated 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Would this cause excess drainage to the laptop battery or cause the laptop to overheat?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,

I have the exactly same problem with Windows 8. I have to enter the Device Manager and uninstall the device driver and install it again to get rid of the problem without rebooting my computer.
I would really appreciate a hint of how to fix this issue.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Here is a fix that is faster than troubleshooting network adapter every time... :D Just run it, and press any key when prompted... :)

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Here is a fix that is faster than troubleshooting network adapter every time... :D Just run it, and press any key when prompted... :)
The script does not work :(, the problem is driver related and not network related. I Found a tip though on Intels site to enable Magic packet (http://communities.intel.com/thread/32930). However it did not work for me either. Now I am trying to update the 82579V driver  (http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=21642&lang=eng&OSVersion=Windows%208*&DownloadType=Drivers) lets hope it helps.....






Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi! Just in case it hasn't been solved it, Intel put up a fix which can be found below.

http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&ProdId=3299&DwnldID=22026&keyword=82579v&lang=eng

Hope this helped!

5 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi! Just in case it hasn't been solved it, Intel put up a fix which can be found below.

http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&ProdId=3299&DwnldID=22026&keyword=82579v&lang=eng

Hope this helped!

Great it works :D, thanks for the tip!

3 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

What worked for me was
Network Connections | Wi-Fi Properties | Configure... | Power Management |
"Allow the computer to turn off this device to save power" - Check the box.

I tried a LOT of other things, but this was my magic 'bit'.

I have seen other solutions referring to Video and SSD drivers, but I believe I have the latest of both.

Win8 64-bit Lenovo T430 Samsung SSD

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.