Limited connectivity on Windows 8 Pro installed on PC

I installed Windows 8 on PC at my school, and then it said "Limited" on the network icon (the screen icon on the task bar that has exclamation sign in front)  and I have tried some simple stuff like, turn off the router then turn on again, delete all the DNS thing, do the "ping" check, nothing happen.... and tried to install protocal on network, still the same problem. Anyone could help my school with this problem? Any possible answer would really be appreciated! 

P.S. how my school router connected like... well, it has got some black box next to it, and there's a LAN wired connect to that box and then connect to the router, and there's a DSL wired connecting to the black box, and then i plug the LAN cable to the router and plug the LAN cable from the Windows 8 PC to that router, it's like...the PC cannot find the internet, anyone could help please? :( 
 

Question Info


Last updated May 18, 2019 Views 9,956 Applies to:
Answer
Answer
This is an annoying problem (and quite common, from what I understand) - especially if you have upgraded from a working OS with a working connection.  A few suggestions:

1)  Check that the OS isnt turning off power to your network card

Control Panel -> Network and Internet -> Network and Sharing Center

Click on the connection you are having trouble with.  This will open up a status window.  Select the Properties button, which will open another window.  Near the top, right side, select the Configure button.  You'll now have a window with multiple tabs (properties of your network card) - which likely says 'This device is working properly.'  Next, select the Power Management tab.  Now, there will be a tick box (likely checked) that says "Allow the computer to turn off this device to save power."  UNCHECK IT.  Select OK.  You shouldnt have to, but you may need to reboot.

That doesnt fix it?  Try option 2.

2) Disable the Bonjour service.

Bonjour gets installed with a lot of Adobe and Apple apps - things like iTunes - and has this annoying habit of hozing the network stack occasionally on a Windows-based machine.  Note that this may not be on your machine, but it is something to check.

Hold the Windows key + R to get the run dialog box and run services.msc.  Find the Bonjour service.  Double click the entry, and in the box which opens, hit the stop button.  Once you've done that, change the startup type to 'Disabled', and click OK.  You shouldnt have to, but you may need to reboot.

Still no-worky?  Then try option 3.

3) Reset the network stack

All Apps -> find command prompt and right click on Command Prompt -> select run as administrator -> select OK at the UAC prompt.

Run this command:  netsh int ip reset C:\resetlog.txt

This may take a few minutes to process.  Once that is done its thing, reboot.


Hope this helps.

10 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.