hp wireless button changes airplane mode

I just upgraded my 64 bit HP Pavilion g7 2010 nr to windows 8. now, whenever i try to use the wireless button (Fn + F12) it changes the airplane mode instead of wifi.
ive updated my wifi card drivers (Ralink RT5390) and and the HP wireless button driver as well
i can use ethernet, but im at school and its not always easy to find a ethernet port

theres no other way to get wifi on because the troubleshooter says to "make sure the switch is turned on"

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Already did BIOS upgrade to F22.  I will try removing HP Power Manager and let you all know.

2 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I have a solution that does not require you to unplug your battery and is a little faster. This may seem like a long process but it's actually very quick once you get used to it.. it's basically just clicking through the right options.

Open control panel and go to Network and Sharing Center.

Go to Change your network settings and choose Troubleshoot Problems.

On the page that opens, choosing the first option, Internet Connections. Click Nect on the window that opens.

It will give you a window with two more options, choose Troubleshoot my connection to the Internet.

It will now look for and detect the problem that you need to "Turn on Wireless capability" Choose the option, Apply this fix. This will reconnect your connection so you can use wireless again.

~~~~~~

 I came across this message base because I to am looking for a better solution to the problem. I realized, my solution was faster than everyone who posted above me and wanted to share it. We really do need a way to turn off this airplane mode function for good and restore our function keys to normal PC functioning.

35 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I followed your steps but mine comes up with "Troubleshooting couldn't identify the problem."  I did not get the "Turn on Wireless capability" prompt.

Thanks for trying.  I agree HP needs to restore normal function to a huge group of product owners.  I am not happy with $1,000 invested in a laptop that does not perform normally.  I can spend a lot less to get a POS laptop.  LOL

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

My wife reminded me sometimes it wont work if other network connections like Local Area Connections are active.. she says to disable all connections before you hit the troubleshooter.

OR

Try this.. I just found out its the best quick fix.. quicker than my post above.

Go to the Network Connections icon in the task bar ( it's the icon with all the little bars)  and use the slider on Airplane mode to turn wireless back on. It's that simple.

I still have a need to disable that button because I accidentally hit it now and then and it's annoying. Plus many games and apps that want to map to the F12 key can't do it because of this airplane mode function.  That's part of Windows 8 mobile features But many desktop users don't need or want a lot of the mobile features in a desktop OS.

The first poster said, " I just upgraded my 64 bit HP Pavilion g7 2010 nr to windows 8. now, whenever i try to use the wireless button (Fn + F12) it changes the airplane mode instead of wifi."

But this is really not the case. Airplane mode IS wifi.. and every other wifi connected device in your system.. it turns them all off quickly so you can be protected at airports and on the airplanes.. hence the name Airplane Mode. It makes sure Wifi and all other devices that are able to connect to any network absolutely cannot run. At least thats my understanding of this silly feature. Well, perhaps not silly if you need it but most desktop users don't.

I have a HP Pavilion G7 laptop I use as a desktop machine. I don't know if this is a Microsoft blunder or HP or a combo of both but I wish they would give you the option to disable the functionality of F12 as it is now.

From Control Panel, Windows Mobility Center does have a way to change the functionality of the F12 button but like me, this feature does not show up in Windows Mobility Center for some unknown reason. Look here: http://windows.microsoft.com/en-US/windows7/Using-Windows-Mobility-Center

2 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

If I open Windows Mobility Center, wireless does not appear.  I am convinced this is like you say, HP or Microsoft or combined blunder.  My F12 does not work other than Airplane mode switch.  There is no slider in Network Connections, etc.

Could be BIOS, could be driver for F12.  In any case, I am weary after no HP solutions since October.  Trust me, NEVER will I buy HP products again.  Nothing.  Sick of it.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

You don't have a slider for airplane mode? That's odd. It's not an HP feature, it's s standard windows 8 feature. Sure you looking in the right place? Look here, this may help: http://www.eightforums.com/tutorials/5355-airplane-mode-turn-off-windows-8-a.html

I have a 3 year old Compaq with Win 7 also made by HP. They use an application that controls the Hp specific function key abilities, which can be uninstalled. Sadly, they didn't use that on the newer systems but bundled the functions in with the system somehow.

Dont be too hard on HP just yet.. these configurations issues may be fixed yet.. I will keep looking and report what I find. Other than these issues I haven't had any major problems with my Compaq and Pavilion. They are budget systems and work well for the price. This HP Pavilion G7 laptop was 425.00 US dollars ( Best Buy) has an AMD A8 quad core, 8 gigabytes of Ram, 512 dedicated video ram but uses up to 4 gigabytes shared system ram for extra video power. 17.3 inch screen. It's my gaming laptop and plays Black Ops 2 and FarCry 3 ( the latest 3d games) on high settings with great frame rate. Other than that Windows 8 has some quirks due to the new user interface you need to get used to, but it works well if you can get past that.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

"...use the slider on Airplane mode to turn wireless back on. It's that simple." was what you said.  My slider turns Airplane Mode on and off.  Not wireless.  Wireless is not an option, it says "Wireless (off)"

Do you understand what I have been saying?  The F12 button is amber.  Will not turn on.  No other place I have seen that will turn wireless on.  I have been using and building computers since 1985 ish and know how to plug in electrical appliances.  LOL

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Yes.. I do understand. Thats why i found this msg base too. When I hit the f12 key it turns off wifi but it also turns off everything wifi enabled/connected. Thats what they call airplane mode.  It turns from white ( looks light blue to me) to amber and hitting it again will not turn on wifi. All the above suggested ways are ways to re-enable wifi - when all you should really have to do is hit the f12 button again - but of course that wont work - it's not set up for that. The easiest and fastest way is using the slider but for some reason, you don't seem to have a slider. I wish i could help you get this slider back.

If you enlarge the little network connection icon bars in the taskbar.. what exactly do you see? Can you post a screenshot?

Another option is perhaps it's the version of windows 8 you have thats somehow different. You could go to the above eightforums and sign up for a free account and ask in there to help you get back the airplane slider function.  Otherwise i will try to research this and help you. I'll get back to you.. in the meantime, please see if you can post a screenshot.

Here is what it looks like on my system. i did notice if the button is amber, you wont see the network bars icon in the taskbar - you will see an icon of an airplane. That's what you want to click. Airplane Mode ON, means wifi is Off. If Airplane Mode is Off, it means wifi is ON. In this screenshot my Airplane mode is On and my wifi is Off. That box next to Airplane mode at the top is a slider. if you have that, drag the white square over to the left. This will turn Airplane Mode Off and wifi back On.

It's confusing.. i know..
 Look at this screenshot: http://imageshack.us/photo/my-images/16/airplanemode.png/

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Remember - look for the icon of the Airplane in your taskbar. It should be there. I have tried to find any version of widows 8 that does not have this feature built in and cannot find any. All retail versions of Windows 8 have this feature. It is the same as the Network Connections application that uses the bars icon you would normally see with Wifi turned on.. only they change the icon to an airplane for airplane mode.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

My taskbar does not have an airplane with Ethernet plugged in.  However the screenshot you provided of the side taskbar, when expanded... mine looks like that.  It says "Wi-Fi (Off)".

If I unplug my Ethernet cable and turn ON Airplane mode, the Airplane Icon shows up.  If I click on that, I get the side taskbar and it shows "Wi-Fi (Off)".  If I turn Airplane mode off, the airplane icon disappears and is replaced with the bars and x "not connected-no connections are available."

If I do a hard shutdown, removing the battery, etc...it may come up with the F12 button working.  Until I do a restart when it reverts to amber and F12 non-functional for turning wireless on and off.  What a pain to go thru that whole sequence every time I use this computer outside of my office in a wireless environment.

By now you should understand that I appreciate your efforts, but please understand that I have gone thru all these steps many many times and have tried everything someone has suggested.  It is not me that is malfunctioning... it is HP hardware or Windows 8.

I still say HP wireless F12 button software or BIOS.

2 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

 
 

Question Info


Last updated January 16, 2021 Views 39,280 Applies to: