Error message: Ethernet doesn't have a valid ip configuration and unable to connect to Internet after installing Windows 8.

Original title: Internet is not working after Installing Windows 8. Please Help

I installed Windows 8 a week ago, which had Windows Vista. When I was using Vista, I had no problems with the Internet I had. But soon after I installed Windows 8 the problem started. The connection hardly stands for 2 minutes. Moreover it doesn't navigate beyond my home page. After troubleshooting the result came as Ethernet doesn't have a valid ip configuration. This really makes me frustrated. after all I was eager to browse through windows 8, this problem makes me think really bad. If anybody could help me, it will be grateful to you.

 

Question Info


Last updated November 2, 2019 Views 189,828 Applies to:
Answer
Answer
Respected Manorajan,
Me too had d same problem but i solved it later on myself.

Here's it how to :-

1- Make sure u have intel network driver installed i ur windows it pc. Download it ( on any other pc and transfer and install it into this one) and install it in ur respective windows 8 pc. Here's the link to download it :- http://drivers.softpedia.com/get/NETWORK-CARD/INTEL/Intel-Network-Adapter-Driver-172-for-Windows-8.shtml
Den download realtek lan driver from here install it http://drivers.softpedia.com/get/NETWORK-CARD/REALTEK/Intel-Realtek-LAN-Driver-80030730-for-Windows-8.shtml..if in installing theres any error ignore it..dont panic and reinstall..as it will already be installed 

2-unplug your LAN cable and wireless connection 

3-Go to network and sharing center den on d left side click on change adapter settings left clik on intel network adapter

4-Go to  "Ethernet Adapter local area connection" properties and deselect ''Internet Protocol Version 6 (TCP/IPv6)''

5- select "Internet Protocol Version 4 (TCP/IPv4)" 

And press Properties button

6- select "Use the following IP address:" option and set this ips

IP= ''ur ip address''

subnet mask=255.255.255.0

default gateway = your router ip  (you can recheck all dis from any other pc having a successful conection wid dis same one by checking the properties of d connection or from any smart phone like any iphone or android mobile if it is used as a wifi too by seeing staus/properties of ur respective wifi name  )

7- from second section select "Use the following DNS server addresses:"

set "PreferAlternate DNS server:" your router ip which u entered in ''default gateway'' above. press ok and try to connect through lan then wireless


51 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.