Windows 8 does not revert automatically to laptop screen after external monitor is disconnected

About a month ago I've installed Windows 8 on my Dell Inspiron 1545. Since then, when I connect an external monitor and set the output to "second screen only" (win-key+p,"second screen only") and later disconnect the cable of the external monitor, the screen of my laptop stays black. I then have to press win-key+p, and try to set it to "pc screen only" (blindly of course, since the screen is still black). This did not happen on Win7: there my desktop was automatically shown on the internal monitor after the external monitor was disconnected. The GPU is an ATI Mobility Radeon HD 4300 series. I tried to install new drivers (including the Catalyst control panel), but I still can't get this to work properly. 
 

Question Info


Last updated March 24, 2018 Views 1,143 Applies to:
Hi,  

 

Connecting another monitor to your laptop or desktop is a great way to get the best out of your PC. You can use one monitor for work (programming, files, work email) and the other for play (chatting with friends, social updates, or movies).

Connect another screen to your PC
  • To connect a monitor to your desktop PC, use a video card that has two DVI (or VGA) ports—most PCs today do, and most flat panel monitors have a matching port. If you have a video card with two ports, you can usually just plug two monitors into the matching ports. Look on the back of your desktop PC for the video ports, and match the cable from each monitor to the corresponding port. These ports connect directly to your video card.

  • If you have a laptop or tablet, plug a monitor into the PC’s DVI, VGA, or HDMI port, and Windows 8and Windows RT will automatically detect the monitor.

In both cases, you might need an adapter to plug a DVI cable into a VGA port or vice versa.

 
Note
  • If you have a video card with only one port, some PC makers include custom monitor cables that split the signal from one port to two monitors.

     

Set up your screens

Once you plug in your screen, you can choose your display options. To do that:

  1. Swipe in from the right edge of the screen, and then tap Devices.
    (If you're using a mouse, point to the upper-right corner of the screen, move the mouse pointer down, and then click Devices.)

  2. Tap or click Second screen and then choose one of these options:

    • Duplicate. You’ll see the same things on both screens.

    • Extend. Your screen is now spread over two monitors, and you can drag and move items between the two.

    • Second screen only. You’ll see everything on the connected screen, and the other one will remain blank.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

TevariRaju, have you actually read my question? Probably you did, but stopped reading when you saw the word monitor. Or you just failed the Turing test. 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have the same issue. I want to use "Second screen only". But whenever I lock my computer using WIN+L and then log back it switches to "Duplicate".

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have the same issue. I want to use "Second screen only". But whenever I lock my computer using WIN+L and then log back it switches to "Duplicate".


Does the dialog switch or just the appearance?  FWIW I occasionally see the latter happen (from Extended) but in my case the two monitors have different resolutions, so when that happens the scaling is wrong on the one with higher resolution.  In that case I can just use Win-P, CursorUp, Enter to set the dialog to match the observed configuration (which then fixes the scaling issue) and then toggling it back to Extended puts them both back to normal.   That symptom can happen just from a simple Sleep situation.  I can't decide if it is a hardware problem or a driver problem.


I see a related symptom when I switch users.  It looks as if the Lock Screen is not considering the Extended case and then after the switch all my windows are taken from my secondary monitor and put on my primary.  Fortunately, in my case that usually only means putting a Fullscreen IE window where it doesn't fit very well.  And strangely, pressing F11 puts it back on the right monitor!  So, pressing F11 twice is my recovery from this quirk.  That's in W8.  In W8.1 Preview something has slightly changed but it is still not perfect.  E.g. sometimes the Fullscreen window does not have to be moved but it doesn't always look right, so then I have to press F11 twice anyway.   ; }

 

FYI

Robert Aldwinckle
---

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.