Why is access denied to a registry key folder that is preventing me from installing a bluetooth driver in Windows 8?

I installed an Intel 6235 WiFi/Bluetooth card and driver in my Acer Aspire One. It worked fine for a few weeks but then my bluetooth stopped working. When I try to reinstall the bluetooth driver I get this message:

Could not open key:
HKEY_LOCAL_MACHINE32\SYSTEM\CurrentControlSet\services\BTHPORT\Parameters\Radio Support.

When I go into the regedit and try to open this folder I get this message:

Radio Support cannot be opened. An error is preventing this key from being opened. Details: Access is denied.

I am logged in as an administrator when this happens. I've tried to install them after a clean boot but get the same errors. I've recently upgraded to the new version of Office and installed Norton Security Suite if that helps. But disabling Norton does not solve the problem. Help!
 
Question Info

Last updated August 4, 2018 Views 10,720 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi,

 

Thank you for giving us an opportunity to assist you with this issue.

 

I see that access to the registry key HKEY_LOCAL_MACHINE32\SYSTEM\CurrentControlSet\services\BTHPORT\Parameters\Radio Support is denied to your administrator account.

 

Let us work together to resolve this issue.

 

It looks like the permissions for the key haven’t been given for the administrator account in which you have logged in.

 

Step 1: Follow these steps to backup the registry files.

 

a.     On the desktop, press Windows key + R, type regedit.exe and press Enter.

b.     Locate and click the key or sub key that you want to back up.

c.      Click the File menu, and then click Export.

d.     In the Save in box, select the location where you want to save the backup copy, and then type a name for the backup file in the File name box.

e.     Click Save.

 

 

 

Step 2: To assign the permissions follow these steps:

 

a.     Open the registry key till Parameters and right-click on it.

b.     Select Permissions.

c.      In the Permissions window, click on the account name under Group or User names.

d.     Then click on the box next to Full Control.

e.     Click on Apply and OK.

 

Note: This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs.

 

Step 3: Try installing the Bluetooth driver and check if the issue is resolved.

 

Please get back to us with the results.

 

If you have any further questions about Windows operating systems, we are always happy to assist you.

Regards,

Manasa Sirahatti

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Having this same problem and this did not resolve my problem, I'm still getting the error about access is denied.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thank you very much! I followed the suggestions and it still fails when I try to install the bluetooth driver, but with a different message:

Could not open key:
HKEY_LOCAL_MACHINE32\SYSTEM\CurrentControlSet\services\BTHPORT\Parameter\UnsupportedServices.

So it seems to have been able to access the Radio Support folder but now it's the UnsupportedServices folder that cannot be accessed. I tried to look at permissions for this folder but it wouldn't even let me do that. Any other suggestions? Thanks again!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I was able to get mine working by giving full control rights to the entire bthport key to "Local Service".

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I was able to get mine working by giving full control rights to the entire bthport key to "Local Service".
Thanks. When I go to the BTHPORT folder and open permissions "Local Service" does not appear in the list of "Group or user names". Any other ideas? 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Ok, guys and gals. This problem was really pi**ing me off. Windows 8 Pro got really dumb on me and I am not totally convinced this is not a bug of some sort. Windows Update Intel bluetooth driver was failing to install and so was Intel's latest bluetooth driver direct from their site due to registry permission problems. So here is the solution. Finally got it to work, but man what a pain in the ****. Go to the registry key BTHPORT and spam all the existing accounts with full permission to that key plus give your admin account ownership over BTHPORT and all children. Then delete the entire BTHPORT key. Make sure you uninstall the Intel bluetooth software as well. Go to device manager and uninstall the unknown device or banged bluetooth device. Reboot. Now try to install the Intel Bluetooth driver. All should be swell again. Basically by you reinstalling after doing all of this the install recreates the reg key it needs with proper permissions. Something in Windows 8 install or updates is hosing the key to begin with and I will leave that to an expert greater than I to figure out. This all happened on a fresh install of Windows 8 Pro 64. Hope this helps.

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Ok, guys and gals. This problem was really pi**ing me off. Windows 8 Pro got really dumb on me and I am not totally convinced this is not a bug of some sort. Windows Update Intel bluetooth driver was failing to install and so was Intel's latest bluetooth driver direct from their site due to registry permission problems. So here is the solution. Finally got it to work, but man what a pain in the ****. Go to the registry key BTHPORT and spam all the existing accounts with full permission to that key plus give your admin account ownership over BTHPORT and all children. Then delete the entire BTHPORT key. Make sure you uninstall the Intel bluetooth software as well. Go to device manager and uninstall the unknown device or banged bluetooth device. Reboot. Now try to install the Intel Bluetooth driver. All should be swell again. Basically by you reinstalling after doing all of this the install recreates the reg key it needs with proper permissions. Something in Windows 8 install or updates is hosing the key to begin with and I will leave that to an expert greater than I to figure out. This all happened on a fresh install of Windows 8 Pro 64. Hope this helps.
Thanks for the suggestions. When I try to give the account "CREATOR OWNER" full permission the check mark just disappears when i click "Apply". Also, how do you give your admin account ownership over BTHPORT and all children? I can't delete it. 

In my case the bluetooth driver worked fine for a few weeks before it lost access to the registry keys. I think it happened when I upgraded Microsoft Office but I can't be certain. I'm wondering if your fix will survive future windows and software updates. Hopefully!

Any Microsoft engineers want to weigh in on this? It doesn't seem to be an isolated problem.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I'm getting the same message.  Unfortunately I don't have HKEY_LOCAL_MACHINE32.  I only have HKEY_LOCAL_MACHINE.  Is this a problem with the installer?  I have the 64 bit version of windows 8

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Yep. Should be in HKEY_LOCAL_MACHINE.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I tried to edit permissions in Parameters on  HKEY_LOCAL_MACHINE, for some reason UnsupportedServices still does not allow anything to access it even though it's a child folder of Parameters.

 

When I try to install my Intel Bluetooth driver I'm still having problem.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.