USB ports do not worjk after installing Windows 8.

I am running an Asus P6X58D Premium motherboard and my usb devices had no problems previous to upgrading to 8.  Currently my and keyboard work only when in my BIOS, once Windows is loaded they do not respond or show up in the device manager (I am VNC'ing in via my tablet).

In device manager, my Intel(R) ICH10 Family Controllers all show up with errors (yellow triangle) as well as the NEC/Renesas USB 3.0 host controller.

I have tried removing all USB devices, uinstall/reininstall of USB controllers, updating via windows update, updating the drivers via the intel website, updating system firmware from Asus, looking for newer drivers from Asus,, and generally scouring the internet to see if there are others with this issue. 

Is this a known problem?  I haven't seen any posts regarding this.  I don't want to have to downgrade but that is a possibility.

Any help or insight would be greatly appreciated.

Thanks!
 
original title : All USB 2.0/3.0 does not work after upgrading from win7 to win8 pro
 

Question Info


Last updated October 27, 2019 Views 3,778 Applies to:
Answer
Answer

Do what CKnospe says.

OK FRIENDS - HERE IS THE ANSWER:

 

To begin, I had the exact problem as OP. I upgraded my windows 7 to Windows 8 about 2 weeks ago, and suddenly ALL 8 of my USB's did not work.

 

I had MS Answerdesk perform diagnostics TWICE to try and fix it, the last time they said their level 2 agents had to work on the computer (but never called).

 

After searching online for the last 2 WEEKS, and finding no definitive answers as to actually fix this problem, CKnospe's option actually worked, but I had to do one thing first: DOWNLOAD AI CHARGER HERE http://event.asus.com/mb/2010/ai_charger/

 

I was going to install and uninstall the program to see if it did anything, since AI Charger didn't show up on the populated programs list.

 

There were 3 options after I unzipped and loaded setup. Repair, Install and The bottom option was "REMOVE"

 

I chose remove, as I didn't even know the program was on my computer (didn't show up on the populated programs list) and it forced a restart.

 

After restart: BOOM, all my USB's are WORKING.

 

Hope anyone looking for an answer to this tries what I did. I can't express how happy I am with this easy peasy fix. Seriously joygasm here.

Peace.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.