Touch screen not working for Asus laptop

i have the Asus - 11.6" Touch-Screen Laptop - 4GB Memory - 500GB Hard Drive - Steel Gray and for some reason my touch screen is not working anymore. It worked perfectly  the other day but today it is not. Does anybody know why and what i can do to fix this problem?

p.s. i already tried restarting my laptop and shutting it down.
 

Question Info


Last updated September 22, 2018 Views 205,183 Applies to:
Answer
I had this issue with my VivoBook S400CA touch screen and fixed it today doing the following:
  1. Go to the Control Panel.
  2. Go to Troubleshooting (you may have to search for it)
  3. Click Hardware and Sound
  4. In the Device section, click Hardware and Devices
  5. Have the wizard scan your computer for hardware issues.
  6. Let the computer fix whatever issues you had.
In my case there were 2 USB input devices that were disabled that the wizard enabled for me.  The touchscreen immediately started working.  Hope this helps someone.

UPDATE:
The problem used to come back periodically.  But since updating all of my drivers a while back, the problem has not resurfaced.

307 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.