Realtek ALC889 does not work after computer wakes up from sleep.

The Realtek ALC889 sound stops working in Windows 8 RTM after resuming from S1 sleep mode, I need to disconnect and reconnect the audio cable in order to restore the sound and I have to do this every time the computer sleeps.  I'm using the latest Realtek R2.70 audio driver.  I tried the audio troubleshooter and it could not find any problems and there is nothing to fix.  The only way to fix the sound is to physically unplug the audio cable and then plug it back in and I have to do this every time I resume from sleep and this could wear out the speaker or headphone jack from repeatedly unplugging and replugging the cable.

 

Original title :Realtek ALC889 No Sound after waking from sleep 

Answer
Answer

Hi KeithWeisshar,

 

Thank you for posting in the Microsoft Community.

Apart from the issue, how are you doing today?

You have an issue with the Realtek ALC889 not working after resuming the computer from sleep. This can be really frustrating for you and I appreciate the efforts that you have put in. Let us work together as a team and try to get this issue fixed.

 

Let us start with few questions-

1)      Is this issue limited to the Realtek ALC889?

2)      Do you get any error message or error code?

3)      Have you made any changes on the computer prior to the issue?

 

I would like more information regarding the issue.

 

Method 1–

I would have you run the Hardware and Devices troubleshooter.

Refer the steps-

a)        Click on “Start” and type “troubleshooting” (without the quotations) and then select “Settings”.

b)       Now, Click on “view all”.

c)       Run the “Hardware and Devices” troubleshooter.

 

Method 2-

I would have you refer the steps-

a)       Hold down the “Windows+R” simultaneously, type “devmgmt.msc” (without the quotes) and hit “Enter”.

b)       Now, identify your device listed under sound and Right Click on it.

c)    Now, select “Uninstall”,

d)   Re-install the latest drivers from the manufacturer’s website.

 

Method3-

I would have you restore the power plans to default.

Refer the steps-

 

a) Click on “Start” and type “cmd” (without the quotations).

b) Once you see the “cmd” icon, right click on it and select “Run as administrator”.

c) Copy and paste the following command in the Command Prompt window and hit "Enter".

 

powercfg –restoredefaultschemes

 

d) Wait for process to complete.

e) Close the Command prompt window.

 

Note: Resetting the power plan settings to default will delete all customized power plans.

 

Do let us know if you need further assistance. We will be happy to help. We, at Microsoft strive towards excellence.

 

Thanks.

 

 

 

 

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated May 15, 2018 Views 3,779 Applies to: