Problems changing from IDE to AHCI in Windows 8

Hey folks --
I've been looking at switching to AHCI mode for our two machines at home.  My wife's is running Windows 7 and mine is Win 8.  Both of them were installed with legacy IDE running, so I've had to investigate how to make the change after-the-fact.  With the Win 7 machine, I found and installed the correct drivers for the motherboard, did the registry hack, etc.  It wasn't as simple as it was supposed to be, but it did finally work.  That last boot, Win 7 grabbed onto the drivers and ran with them, and now the machine is humming along in AHCI mode.

My Win 8 machine is a different story.  The registry hack is a little different, and there are a couple different variations, none of which has succeeded in producing anything but the BSOD.  I also found a method using Safe Mode, but this doesn't work any better.  At this point, I have the BIOS with SATA Configuration set to "AHCI", but at POST it still recognizes all my drives as "IDE".  The "Standard AHCI Controller" is showing up in Device Manager as "working properly", and it says its drivers are all up to date.  What am I missing?  (For that matter, is there someplace other than POST where you can actually find Windows saying it's running in AHCI mode?)

Before anyone asks, here's what I'm running:

ASUS M3A78-CM motherboard, Socket AM-2 (latest BIOS, #2801)
AMD Athlon 64X2 6000+ 3.1GHz processor
Windows 8 32-bit, Build 9200
4GB RAM
OCZ Agility 4 256GB SSD (basically, the main reason I want AHCI and NCQ, so I can have TRIM support)
Seagate 1TB SATA HDD
Seagate 1.5TB SATA HDD
SATA DVD-RW
IDE DVD-RW (this is currently the only real IDE device in the system)

The registry hacks are all some variation under HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\storahci\, but some say to change Error Control VD to 0, while some say to change Start VD to 0, some say to change StartOverride to 0, some say to delete StartOverride altogether, etc.  I haven't found the magic combination, yet.  Each one results in a BSOD, Windows diagnosing itself, and giving me a Restore option.

The Safe Mode option results in a clean boot, but Windows still does not go into AHCI mode after the BIOS change.  One version of this approach recommended simply uninstalling the IDE controller in Device Manager, supposedly forcing the AHCI controller to install at reboot.  The problem with this is that I do have that one IDE device plugged up, and so the system knows it needs to reinstall IDE for that.  I tried simply disabling it, and the AHCI controller did install (as in, it shows up with good drivers in Device Manager), but still POST shows IDE drives.  (One option that occurs to me is to try this with the IDE optical drive unplugged, and see what happens.)

I'll keep trying various combinations of both, but I thought I'd see if anyone has anything good to offer, here.  (Each attempt is time-consuming, waiting for Windows to diagnose and "repair" itself... I only have time for one or two of those, before work.)


 

Question Info


Last updated March 24, 2018 Views 13,026 Applies to:

Hi Roff,

 

 

 

It seems you would also have to make certain changes to the settings in BIOS after going through the changes in registry in order to change the SATA hard driver mode from IDE to AHCI mode.

 

 

I would suggest you to contact the manufacturer of the computer for further help on this specific issue.

 

 

Do get back to us if you have more queries on Windows.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,

 

Take a look at the last replies from sonnyriley at this thread... a bit different than you mentioned...

http://answers.microsoft.com/en-us/windows/forum/windows_8-performance/how-to-change-sata-config-from-ide-to-achi-in-win/1cb3350f-22ff-4775-969e-876e1fd5c4ed

 

I'm surprised that you were able to boot with your OCZ Agility 4 256GB SSD in IDE mode at all...

My Vertex 4 flat out refuses to boot in IDE mode... It booted once after the installation, but after it was recognized as "New Hardware", it wouldn't boot again...

 

ALSO... check your BIOS to make sure you don't have more than one SATA controller... a lot of motherboards do, and they may each have their own AHCI\IDE setting...

 

If you actually have a IDE port, that may be part of the problem... it may be running off of the same controller as your SATA... You might try unhooking it and see what happens...

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,

 

Take a look at the last replies from sonnyriley at this thread... a bit different than you mentioned...

http://answers.microsoft.com/en-us/windows/forum/windows_8-performance/how-to-change-sata-config-from-ide-to-achi-in-win/1cb3350f-22ff-4775-969e-876e1fd5c4ed

 

I'm surprised that you were able to boot with your OCZ Agility 4 256GB SSD in IDE mode at all...

My Vertex 4 flat out refuses to boot in IDE mode... It booted once after the installation, but after it was recognized as "New Hardware", it wouldn't boot again...

 

ALSO... check your BIOS to make sure you don't have more than one SATA controller... a lot of motherboards do, and they may each have their own AHCI\IDE setting...

 

If you actually have a IDE port, that may be part of the problem... it may be running off of the same controller as your SATA... You might try unhooking it and see what happens...

Nope, just one SATA controller.

The information Sonny got was similar to what I found earlier, though opinions differed as to whether it was best to tweak StartOverride from 3 to 0 or to remove it altogether.  I've tried both.  Somewhere between these registry hacks and the Safe Mode method, I seem to have it running in AHCI mode... but not.  The AHCI Controller is active in Device Mgr, and the driver (storahci.sys) is showing as "up-to-date" and doesn't want a better one.  HOWEVER -- Anvil says my drives are running in IDE mode, and that is still the way they show up in POST.  I'm kinda scratching my head, here... 
DJ

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

It seems you would also have to make certain changes to the settings in BIOS after going through the changes in registry in order to change the SATA hard driver mode from IDE to AHCI mode.

 

I would suggest you to contact the manufacturer of the computer for further help on this specific issue.

 

Do get back to us if you have more queries on Windows.

Changing the BIOS switch from IDE to AHCI is always the last step in any of the solutions.  With the Win 7 machine, it was like magic after that reboot.  Not so much, with Win 8.

I have been talking with the manufacturers, but this is a custom build, so "manufacturer" could be several different people, including me.  ASUS tells me I only need the driver supplied in Win 8, although they do have a suggested set of drivers for download (but at 4 years old, they appear to be geared more for Win 7 than 8).  AMD has an AHCI driver installation package which requires Catalyst Installer, makes a lot of splashy panels on the screen but nothing else.  Nobody seems to have the one "right" answer on this one, but it sure seems that Win 7 did a stellar job of handling the whole issue, while 8 needs to be poked with a stick.
DJ

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,

 

I'm don't know anything about Anvil, but it if your drives are in AHCI Mode, they will show up in the "Safely Remove Hardware" list on the lower right of your taskbar...

 

That icon displays permanently when SSD\HDDs are in AHCI mode...  because they are now hot swappable.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,

 

I'm don't know anything about Anvil, but it if your drives are in AHCI Mode, they will show up in the "Safely Remove Hardware" list on the lower right of your taskbar...

 

That icon displays permanently when SSD\HDDs are in AHCI mode...  because they are now hot swappable.

THANK YOU!!  Believe it or not, that is the first mention I've seen of that particular point.  I think this qualifies as a "Doh!" moment.  I just never thought to look there, but of course they should show up as "ejectable", if they're now hot-swappable.  And the answer is...   YES!  All my drives are showing up there.

As for Anvil:  http://www.guru3d.com/files_details/anvils_storage_utilities_download.html  It's just a utility that gives you drive benchmarks, etc.  Sweet, because it runs as a free-standing app, no installation.
DJ

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,

 

Good Deal...Lucky Guess... glad it answered the question...

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Just as a final note... I followed up this train of thought by looking at Properties for each of the drives, and lo and behold, each of them (other than the active system drive) is now showing hot-swap choices under a "Policies" tab.  The default is to have them "ejectable" under that pop-up in the system tray, but the other option is to leave them as removable-at-will, without needing the ejection pop-up.  Supposedly the default option gives a little better performance.

Also, on my wife's newer Gigabyte board, there was an additional step to take in the BIOS, which this led me to... her drives weren't showing up the same way.  Turns out you have to go drive-by-drive to enable "ESP support" (eSATA Port, I believe), which causes that Policies tab to appear in Properties.  After that, they all appeared in the systray pop-up, just like mine (except for her active system drive, on which I left ESP disabled).

Many thanks, again, for the helpful nudge in the right direction!
DJ

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,

 

It is a little slower using the "Safely Remove Hardware" method, but very slight...

The advantage of using it is that it insures that any data still in the drives Cache is written to the disk before ejecting...

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Here is a method that worked for me in switching to ahci from ide in Windows 8.1. I have cut and pasted the web article.

In later posts on the Microsoft Community, changing the bios setting to ahci and then booting up in Safe Mode by hitting the F8 key several times at boot also performed the change automatically.



A lot of users have been messing around with AHCI after installing Windows 8. Some users have reported that they can’t get Windows 8 to install without disabling AHCI. Here at iTD, we haven’t faced any such issue though we have a quick fix for such a situation. It’s very easy to enable AHCI after installing Windows, although it isn’t visible to users as a simple switch on/off option.

What is AHCI and why should you care?

AHCI ( Advanced Host Controller Interface ) offers native command queuing and hot plugging through SATA host controllers (Serial-ATA) for hard drives. In simpler terms, there’s no reason you shouldn’t use it.

So, how do you enable it? Do you have to reinstall Windows 8 again?

No. You can enable it without losing any data.

Enabling AHCI in Windows 8 requires going through the registry ( yes, it’s still there! ) but it’s slightly different than how it was done in Windows Vista and Windows 7. You still have to modify a registry key but the key is different now. Follow the guide below to enable AHCI in but make sure that you’ve backed up your data as well as registry, just in case.

  1. Exit all applications
  2. Go to the start screen and type in regedit.
  3. If you see the UAC (User Account Control) dialogue box, just click continue.
  4. Locate the the following registry subkey:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\storahci\

  5. Locate the Error Control entry which should have a value of 3. Right-click on the entry name, select Modify, change the value from 3 to 0 and click OK.
  6. Open the StartOverride folder and locate an entry named 0 with a value of 3. Change the value to 0 by following the procedure in step 5.
  7. Restart and enable AHCI in your system BIOS
Quick Alternate Method

If you don’t feel safe playing with your registry like I don’t with a neighbor’s dog ( except that I can handle a messed up registry but not a messed up dog ), I suggest you download the registry file I’ve uploaded here. Just extract the .reg extension file from the compressed folder and run it and restart your computer. Do the obligatory AHCI switch on from your system BIOS and you’re good to go.

Disclaimer

As usual, the author and owner of this website aren’t liable for any loss caused by the above guide. If your neighbor’s dog bites you, your computer blows up or hard drive refused to work, I hereby take no liability. Of course, if you say please, I’ll be more than happy to help. :)

Update: updated with some input from Lyrad Kcirhor, thanks!

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.