Logitech USB headset not working after Windows 8 Pro upgrade

Hi all,

I have a Logitech H530 USB headset that worked brilliantly for me in Windows 7. Then I upgraded to Win8 Pro. Love the OS, but the headset no longer works... audio is fine through speakers, but when I plug in the headset, there's no sound through it. The speakers still play.

Under Playback Devices, the headset doesn't show up. Neither does the mic built into it show up under Recording Devices.

When I go into my Device Manager, it shows up as "Logitech USB Headset" with that lovely exclamation point. As a Plug-and-Play device, there's no specific drivers for it, but the standard Windows USBAUDIO.sys file fails to work with it. I've uninstalled/reinstalled drivers for it, but always under General in the device properties, it says "This device cannot start. (Code 10) A device which does not exist was specified."

Oddly, I can control the system volume using the volume buttons on the headset...

Please help. I'm at wit's end. I have run the Windows Audio Playback Diagnostic tool, I've Googled "Code 10" (which seems to be a very generic error), I've reached out to Logitech (useless and then some thus far).

Thanks if you can help!

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi El Rubio,

 

Thank you for posting in the Microsoft Community.

 

From your issue description I understand that you are facing issue with “Logitech H530” USB headset not working. Please let me know if I have misunderstood the issue.

 

In order to provide you with a quick resolution, please reply to these questions:

 

1.       Do you receive any error message or error code?

2.       Have you made any changes on the computer prior to the issue?

3.       Did you try using a different USB port or device and check?

4.       Is the issue confined to “Logitech H530” USB headset?

 

I’m glad to provide you with these methods which will help you to troubleshoot the issue.

 

Method 1: If the USB device is not getting detected in Windows 8, then I would suggest you to run the hardware troubleshooter to diagnose the exact issue.

 

Follow the steps:

 

a.       Press “Windows + W key”.

b.      Type “Troubleshooter” in the Search box and hit enter.

c.       Select “Hardware and Sound” from the Troubleshooter Window.

d.      Select “Hardware and Devices” under Devices option.

e.      Follow the On Screen instructions.

 

Method 2: I would suggest you to uninstall the USB controller from the device manager. Then download and install the latest “Chipset” driver from the manufacturer’s website and then check whether your “Logitech H530” USB headset works.

Follow these steps:

a.       Press “Windows key + W” from your keyboard.

b.      Then type “Device Manager” without quotes in the search box and hit enter.

c.       Expand “Universal Serial Bus Controller”.

d.      Right click on the each controller and select “Uninstall” option.

e.      Then restart the computer for changes to take effect.

f.        Then download and install the latest driver from the “Motherboard” manufacturer’s website.

 

Method 3: You can try setting the headphone as default and check if the issue persists.

 

a.       Right click on the volume icon in the system tray and then click "Recording devices".

b.      Right click on the blank space in the popped up window and then select "Show Disabled Devices" and "Show Disconnected Devices".

c.       Right click on Headphone and then click "Enable".

d.      Highlight the microphone and then choose "Set as Default Device".

e.      Click Apply and Ok.

 

If you need further assistance, please reply and we will be happy to help you.

 

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Have you tried using your USB's for anything else?

 

If you have AI Charger installed, you need to remove. Go to  http://event.asus.com/mb/2010/ai_charger/

 

Download latest file, on setup one of the options is "Remove/Uninstall" Do this.

 

Restart computer. Your USB's should work again.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I am having this EXACT issue with my Logitech USB headset. None of these troubleshooting steps works and there is no driver download from Logitech's website. When I try to update the driver, it fails.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

In  playback devices right click on the headset. Click properties. Click advanced. Set to 16bit (FM Radio Quality). this fixed all the problems for me

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have the same problem in my Logitech ClearChat PC Wireless.
I was trying to resolve the problem on logitech forum but without resolve
http://forums.logitech.com/t5/Headphones-Headsets-Microphones/Problem-with-Logitech-ClearChat-PC-Wireless-Windows-8/td-p/926222
After that I contact to logitech via email support but my case get sooo unqualified guy, that i don't believe he will help me (for a month he write to me on child level with standard messages).
So maybe on microsoft forum someone will help us, because logitech site http://logitech-pl-emea.custhelp.com/app/answers/detail/a_id/32426 says our headset shoudl work ok on windows8 :(

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Another one with the same problems.

I 'fixed' my sound by changing it from 7.1 to 5.1.
But 7.1 doesn't work in windows 8 it seems.

With that I can't seem to get my mic to work either.

I tried running all my settings but nothing seems to work.


Bit I'm not running a logitech headset.

I have a Razer Megalodon USB headset.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I found out with my Razer Megalodon, that plugging it into my USB3 solved all problems. Worth a try with your logitech as well guys!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I don't have USB3 port.
And I don't see option to change 7.1 to 5.1 in Logitech ClearChat PC Wireless. :(

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Having issues with USB Microsoft Lifechat LX-3000 and USB VoIP Device (Rosetta Stone Headset). First the Lifechat would not work on a new Win8 laptop, sound came through the laptop speak but not the headset.  Moved them over to a desktop running Win7 where the VoIP Device had been working perfectly and had same problem.  Now neither device works on either system.  Have checked both Playback and Recording tabs in the Sound properties and both devices seem to be installed correctly and test fine on the Playback tab.  Any suggestions would be appreciated.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I don't have USB3 port.
And I don't see option to change 7.1 to 5.1 in Logitech ClearChat PC Wireless. :(
You can change to 5.1 in you windows sound options:
Rightmouse the speaker icon lower right corner( the windows speaker icon) -> Playback devices -> Configure...

(Hope it helps, I had to translate the menus myself)

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

 
 

Question Info


Last updated June 19, 2020 Views 23,165 Applies to: