Issue with sleep, computer wakes up automatically.

Original Title: My Computer Has Insomnia!

 

My computer has a chronic problem with waking up from sleep mode. In Event Viewer I get this error in the information pane-"Intel(R) USB 3.0 eXtensible Host Controller - 0100 (Microsoft)" and then a sleep time and a wake time.  So I assume it's something attached to my usb hub that's waking the computer.  Both external hard drives shut down after a period of inactivity so I'm not sure why this is happening.  None of the usb settings are unchecked to allow the usb device to wake the computer.  I went back to default mode on the power options, and no change.  Allow wake timers is unchecked.  Any advice would be great.  The Intel usb drivers are up to date.  Windows 8 64bit, Toshiba p875-s7102.

Hi Eric,

 

This issue may occur due to incorrect power settings or due to conflict between third party applications.

Method 1:
Let's first run the Power troubleshooter and check of it helps.


a: Press Windows logo + W to open the search box.
b: Type troubleshooting, hit enter.
c: Now click System and Security.
d: Click Power.


Method 2:
If the issue persists,
I would suggest you to set the computer in a clean boot state and check if it helps.

Setting the system in a clean boot state will help to identify if any third party applications or startup items are causing the issue.


How to troubleshoot a problem by performing a clean boot in Windows 8, Windows 7 and Windows Vista


Note: After clean boot troubleshooting steps, follow the section "How to reset the computer to start as usual after troubleshooting with clean boot" in the provided link to return the computer to Normal startup mode.


Refer to the link for additional information.

Power plans: Frequently asked questions
http://windows.microsoft.com/en-US/windows-8/power-plans-faq

 

Hope this information helps. Reply to the post with updated status of the issue to assist you further.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I'm going to try the power settings to default method and see if that fixes this.  The only thing I would change would be requiring a password at waking-I'm the only one using the computer anyway.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Hi Eric,

 

 

Thank you for the reply.

 

 

Please try that steps and keep us updated on the status of the issue. To restore power plans to default, you may refer to these steps.

 

Restore the power plans to default:

a)      Right-click on Start button and click on Command Prompt (Admin).

b)      In the command prompt, type powercfg –restoredefaultschemes and hit Enter.

c)      Exit command prompt.

 

Note: This would reset the power plan settings to default. Any customized power plans are would be removed.

 

Hope this information helps. Reply to the post with updated status of the issue to assist you further

1 person found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Tried everything-computer still does not sleep as per the balanced (or any other) power plan.  I've simply resigned myself to just hitting the power button (which puts the computer to sleep) when I walk away.  I was able to fix a problem with my mouse waking the computer (some command line entry-I forget where I saw it), so when I put it to sleep, it stays there.  I do have a problem getting into safe mode, which I will start a separate thread for.  Thanks.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Hi Eric,

Glad to know you fixed the issue. Thank you for sharing the resolution, as this would help other members of the community facing the same issue.

Please feel free to reply, in case if you need any further assistance or information on this issue.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

This is due to a bug in the default Intel USB 3.0 driver provided by Windows. Whenever you connect a device through the USB 3.0 port, the Toshiba laptop will be waked up by that device (even when the device is just a USB disk). The solutions are either updating the Intel USB 3.0 driver or removing the device before entering sleep.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Hi Geethu B,

Re: Method 1 from your first post is horrible, it did nothing but change settings I had manually set the way I wanted them to something else and did absolutely nothing to the wake settings regarding either software or hardware!

So that just created extra work for me to comb through the power settings and return my display sleep timers computer hibernate timers etc to the way I had them.

The insolent program doesn't even ask you if its OK to make each of those changes, it just applies them as if it owned the computer.  Much of Microsoft's software acts in an insufferably patronizing way.

Re: Method 2 from your first post should have a disclaimer added, that it is only useful for the computer-iliterate, and those capable of following simple instructions for using the CMD command line can save themselves a ton of time over all that rebooting and letting windows do stuff on its own, thats most likely not what you want.

Its not that hard to explain to:  press "Windows key + S"  type "CMD" into the box, hit enter, then right click on the CMD icon that comes up, click "Run as Administrator:

Then explain how to use commands like:

powercfg -lastwake
powercfg -devicequery wake_armed

And the device manager.

Lastly, Microsoft needs to tell people about disabling software wake timers like Windows Update, so it will only update if the computer is on anyway and not wake it up to do that.  Especially given that windows update generally fails to put the computer back into hibernation after its done, or shut it down, if it was off. 

Otherwise, you not only pollute your room with electro-smog from the WiFi adapter all night while you're sleeping, but your battery may be run down when you wake up in the morning.

Computers and their software should be servants to their owners, not masters.

Re: Method 3 from your second post:  Don't automatically assume that user changes caused the issue and therefore the "default" power plan will fix things.  Far from it, as Microsoft's default configuration allows all sorts of wake triggers, including mouse movement.  Imagine you just move the mouse out of your way at the desk, or even just bump your table and bang, computer turns itself on.  And like I said, there's the Windows Update wake timer, that none of your "Methods" will fix. 

Some Windows updates may fix important security holes, but the computer is really not at risk while its turned off!So it should be an obvious and clear choice offered in the Windows Update settings - a simple check box to wake or not to wake for updates - not requiring anyone to dig into the bowels of windows to relieve that kind of annoyance.

For the infernally patronizing Windows 10 for example, even doing the following is not enough:

Control Panel > Power Options > Change Power Plan Settings > Advanced > then scroll down to "sleep" > open "Allow Wake Timers" > click to disable.

This works in Windows 7 and Windows 8, but in Windows 10, Microsoft will unbelievably just change the settings back on its own!

I just had windows 10 for one month and had to revert to windows 8.1, because Microsoft is seriously trying to take over control of MY computer.

In Texas, this would be considered trespassing.

Those who would trade their freedom for security will end up with neither.

1 person found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I solved by going to each power plan and going into advanced energy configuration, next to suspension settings and DISABLED the option allow wake up timers

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated April 6, 2021 Views 5,787 Applies to: