Question

Q: Insert a Disk into Removable Disk USB Drive Error - Need help accessing USB files! This thread is locked from future replies

My USB drive initially worked fine (I can access the files and all) but then there was a pop-up saying the drive needs to be repaired. At first I ignored it as I needed to save some files, and there was no obvious problems. I disconnected and reconnected the USB drive and it was acting normally, but the pop-up came again - this time I agreed to have it scan and repair (I'm using Windows 8). However, when I tried that, it failed, and from that point on, I couldn't access the files within the USB. Heck, its name doesn't show up and 'Removable Disk' takes its place. If I try to access this'removable disk' I get the following error message: 

Please Insert a Disk into Removable Disk [drive letter] 

and the properties show that there is no memory used nor is there any available. Can someone, please, please tell me how I can access it, or at least recover all my files from it. I'm begging you, there is so much work on there I do not want to lose - ranging from word documents to .psd and .ai files for adobe photoshop and illustrator. I'm in full panic mode. Any help will be dearly appreciated.

Answer

A:

Hi Grim,

Please answer these questions in order to understand the issue better.

  1. Did you try connecting the USB device on another computer and check if it works?
  2. When you USB scan and repair did you get any error message, when it failed?

This could happen due to the default behavior of Windows when you may have same drive assigned to a network drive or other hardware drive and removable pen drives tries to occupy the drive as drive letter.

In order to resolve the issue, use the following methods given below:

 

Method 1: Insert the removable disk in the removable drive before you start your computer. But in this case, make sure that the first boot device in BIOS is not USB drive, else computer may not boot at all.

Follow these steps:

 

  1. Log in as Administrator account in windows or any other account with administrative privileges.
  2. Press Windows key + X and click Disk Management
  3. Right click on your removable drive partition and select Change Drive Letter and Paths under Disk Management ( you can find your drive easily through size )
  4. Change the drive letter some other drive letter like X: or Z: which is not reserved by some other drive on windows.

 

Method 2: Run the Hardware and Devices troubleshooter refer to section “Run the Hardware and Devices troubleshooter” from this link:

http://windows.microsoft.com/en-in/windows-8/what-device-isnt-installed-properly

 

Hope this helps. If you need further assistance with Windows, let us know and will be glad to help.  

John Rubdy
Forum Moderator | Microsoft Community

Did this solve your problem?

Sorry this didn't help.

294 people were helped by this reply



 
Question Info

Views: 102,330 Last updated: April 21, 2018 Applies to: