Error installing drivers: The system cannot find the file specified.

I recently purchased a Logitech G930 wireless gaming headset and I'm getting the "The system cannot find the file specified." when I try to install drivers for the device.

I've installed both the software in the CD and the software I downloaded from the downloads page on their website. The drivers for the volume scroll etc. are working, it's only the USB Audio driver that won't work. I've tried cleaning the temp, restoring to a restore point etc, same issue. Unable to get any sound so far. I don't have any modifications that would relate to the issue that I know of, and I was redirected here by the Logitech support people as I was able to install on another PC. 

Help is much appreciated.

Question Info

Last updated January 3, 2019 Views 24,895 Applies to:
I have solved it. 

Created the 
folder repeatedly mentioned in the log and copied all files there. Then made the driver installer search for the driver in C:\Windows\System32\DriverStore. 


^^ Kudos to that dude.

44 people were helped by this reply


Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.