Does the AMD switchable graphics card works on Windows 8?

I have a Lenovo e520 same problem Error 43 Lenovo tell me to go back to Win7Pro Amd and Leshcat drivers do not work.  The problem looks to cause heavy battery use even though device manager says it is disabled. 
 

Question Info


Last updated September 27, 2018 Views 1,056 Applies to:

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thanks for your reply. I have a Lenovo E520  I have tried all the AMD beta and Leshcat drivers.  The AMD beta work until reset so I think it is a Bios problem .  Lenovo support UK  are no help.  As you say HP requires a Bios update I have no choice than to wait for Lenovo   I will go through all your suggestions again but do not hold out much hope  

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

DominicP
Thanks for your help I think I have finally got my AMD driver working OK on my Lenovo E520.  Lenovo released  Intel Display software but I could not get it to install.  Intel install Aborted, reported incompatible or in use when installing WiDi. To fix this I installed all the latest Intel driver for the Wireless Network adaptor and Intel Wireless ProSet 15.6.64.   The Lenovo/Intel WiDi then installed OK..  This updated my  Intel HD 3000 driver I then went to the Amddriver update from Device manager and it went off and found a (Microsoft?) driver. The old driver was AMd 12.100.17.0 the new one (older date) is AMD 9.0.0.0   The same driver is shown for the Intel HD Graphics 3000.
Checking revision number I noticed my Wireless had rolled back to 15.4.64 I tried updating but since then Can not load or run the Lenovo WiDi again.  But at least I do not have any disabled devices..  

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.