atheros ar8161 driver missing gigabit setting

I have an HP Envy Phoenix h9-1340t desktop PC that has a Qualcomm Atheros AR8161 NIC.  I am running Windows 8 Pro 64 bit.  This is a gigabit capable NIC card.  However I am only getting a 100mb connection to my router.  My router is gigabit capable and I confirmed that if I connect another PC with a gigabit NIC that the PC does connect at 1.0 gb so I know the issue is not with my router.  When I look into the speed and duplex settings for this NIC,  I do not see1000 as an option.  I only see 10, 100 and auto.  So I think the problem is with the driver.  The driver is published by Microsoft and I have the latest version which is 2.1.0.7.  Does anyone know why Microsoft has released this driver with no gigabit capability when the NIC card has it?  Does anyone have a solution to my problem?

 

 

Question Info


Last updated September 18, 2019 Views 12,415 Applies to:
Answer
Answer

Well my experience with HP support was extremely frustrating over the last month.  They never solved my problem.  However I got lucky in that I finally found this article on the web

 

http://superuser.com/questions/504197/gigabit-connection-between-2-computers

 

and sure enough the solution in the article worked for me as well.  When I switched from using a CAT5 cables to CAT5e cables,  then I got my gigabit connections.  I wish this information was easier to find on the internet and would have saved me a lot of headaches.  Anyway,  I hope this post will help others and save them the hassle that I had to go through in figuring this problem.

 

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.