Acer Aspire 4750G - Bluetooth not working after installing Windows 8 Pro

After installing windows 8, I have already download bluetooth driver from http://www.acer.com.my/ac/en/MY/content/drivers (Broadcom-Bluetooth Driver) and after install the driver, inside the wireless setting the bluetooth on/off button is has appeared, however it can't turn on ... the button grayed out and i can't use...

Please help ....
 

Question Info


Last updated March 24, 2018 Views 625 Applies to:
Answer
Answer
After installing windows 8, I have already download bluetooth driver from http://www.acer.com.my/ac/en/MY/content/drivers (Broadcom-Bluetooth Driver) and after install the driver, inside the wireless setting the bluetooth on/off button is has appeared, however it can't turn on ... the button grayed out and i can't use...

Please help ....

Hi

 

Here are links to a couple of articles about current, known issues, with BlueTooth devices on Windows.

 

A Bluetooth mouse or keyboard fails to reconnect after being left idle:
http://support.microsoft.com/kb/2758967

 

Bluetooth devices fails to enumerate once SelectiveSuspend enabled:
http://support.microsoft.com/kb/2833716

 


If these articles do not apply to your computer, I suggest you check with Asus support about any known issues or updates for the BlueTooth drivers.

 

ASUSTeK Computer Inc. -Support- Troubleshooting:

http://support.asus.com/download/Options.aspx?SLanguage=en&type=9

 

This will have the information about the hardware devices installed on that specific model and the download for the latest drivers.

 

You can also discuss this issue with others who have that model.

 

ASUSTeK Computer Inc.-Support Forums:

http://vip.asus.com/forum/default.aspx?SLanguage=en-us

 

Regards

MVP 1999 - Present
Windows Insider MVP

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.