Windows 8 64bit can't open chm files

Hi,

I have a user who can't display any .chm help files on their Windows 8 64bit machine. These are help files that reside on the local hard drive (C:\Program Files\...) and NOT on a server share. Upon opening them (either by double clicking the .chm file or opening it with F1 in the application) they are displayed with a "Navigation to the webpage was cancelled" message. 

This appears to be the same issue that tons of people have on their shared or downloaded .chm files, but for this one user it is for ALL local .chm files. 

Things I have tried:
  1. Using HHReg application to change the MaxAllowedZone to 2 (which I wouldn't expect to have any effect since it's the LOCAL files that won't work)

  2. Using HHReg application add the path to the .chm file to the UrlAllowList.
To further complicate matters, my own Windows 8 64bit machine can open .chm files perfectly without any problems. Granted I am a software developer so I have a ton of programs installed (including the HTMLHelp Workshop) that might be fixing this problem for me? I'm really not sure why it works for me and not for this one user.

So, anyone have any ideas?


 

Question Info


Last updated July 2, 2019 Views 55,356 Applies to:
Answer
Answer
The only thing that worked for me was to Uncheck the box "Always ask...when opening this file..." when you first open the file. Afterwards, the popup no longer appears and you can read the CHM file's contents.

23 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Answer
Answer
Alright, I solved my problem. I re-registered the HTMLHelp dll and ocx files and everything seems to be working properly now. Just open up a command prompt (with admin rights) and run the following commands:

regsvr32 hhctrl.ocx
regsvr32 itss.dll
regsvr32 itircl.dll

You'll get a "success" dialog after each one. That's all there is to it! No reboot required and everything was magically working as it should. 

48 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.