In Windows 8 64, Can not remove read only attribute from folder inside of a programData folder

Hello!

The Problem:
I am trying to remove the read only attribute of a folder living inside of the ProgramData folder. I ran into this problem once before with windows 7 defender years ago. So I know this problem can not be resolved by my suto windows 8 administrative privileges. I have already done the security tab
with the add full admin control and become the owner of the file with the Auditing and the jello pudding pops but no dice so I know that this can only be resolved by a series of commands in the cmd that I don't know.

Platform:
Windows 8 64bit

Error message:
You will need to provide administrator permission to change these attributes

The path in question:
C:\ProgramData\Microsoft\Windows\Start Menu\Programs\folder

What I need:
can someone please give me the on and off cmd commands for windows 8 that can grant me real full admin access to all my files and folders?
I only need to shut down the protection to perform some actions with the folder then I can turn the protection back on.
by extension If possible could you include the the cmd commands to disable the protection for only 1 specific folder/file if that is possible?

Thank you for taking the time to read
any help is appreciated!

Answer
Answer

I used to following process to give my Silverlight program access to a set of server file folders (running client/server on the same machine). The folder attributes still say they are read-only (VERY STRANGE), but I no longer get the access error when my Silverlight application runs.

1.       Left-click on the folder (for those of you that still use a mouse).

2.       Select Properties.

3.       Click Security tab.

4.       Click Advanced.

5.       Click “Enable inheritance” if disabled.

6.       Click “Replace all child object…” check box

7.       Click OK.

8.       It may take some time for Windows to change the settings.

After I followed the above steps, my Silverlight client can now access IIS 7 server.

Cheers…

37 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

 
 

Question Info


Last updated April 7, 2020 Views 118,484 Applies to: