I am having trouble deleting my Windows.old folder due to file permissions.

I have an HP h8-1000z running Windows 8 Pro (a home install). I recently just cloned my hard drive from a 1TB Hitachi to a 120GB Intel Cherryville SSD. Going to such a small drive, I'm looking to get as much room as I can freed up. My windows.old folder is about 10GB of wasted space at the moment. I have tried adjusting the Ownership of the folder and the files contained in conjunction with changing the permissions. My account is an Admin account but even when I adjust the permissions to allow for full access to admins, I still get the following error message:

Folder Access Denied
You need permission to perform this action
You require permission from josh-HP\Administrators to make changes to this folder.

(josh-HP is the name of my rig).

I have tried giving permissions to users, administrator, administrators, and everyone but nothing seems to work. I even attempted to delete the file in safe mode to no avail. If anyone has any reccomendations they could make, my ears are wide open.

Josh Cunningham
Student and Tech Junky 
 

Question Info


Last updated January 11, 2019 Views 18,065 Applies to:
Answer
Answer

Hi,

How to remove the Windows.old folder
http://windows.microsoft.com/en-US/windows-8/how-remove-windows-old-folder

How to Delete the "Windows.old" Folder in Windows 8 (several methods)
http://www.eightforums.com/tutorials/2527-windows-old-folder-delete-windows-8-a.html

How to retrieve files from the Windows.old folder
http://windows.microsoft.com/en-US/windows-8/restore-files-upgrade-windows-old

================================

If needed :

1. Open a Command Prompt (Admin)

From the Desktop - WinKey + X  OR Right Click in the lower left hand corner -
Command Prompt (Admin) ; OR from the Start Screen just start typing CMD
or from the Charms Menu - Search - Apps - CMD -> then Right Click on it -
then on lower screen "Run as Administrator".

2. The Prompt probably looks like C:\Windows\System32>

Type this at the prompt and then hit ENTER

CD\

Now the prompt should look like C:\>



3: Type this at the prompt and then hit ENTER

DIR Windows.old

Should look like C:\>DIR Windows.old   

It should return

Directory of C:\Windows.old

and show the contents of Windows.old

That is just to make sure the Windows.old  folder is under C: (the C Drive) - if not STOP



4.
 Type this at the prompt and then hit ENTER

 Attrib /S -r -a -s -h Windows.old

Should look like C:\>Attrib /S -r -a -s -h Windows.old
(there are SPACES between Attrib and /S and -r and -a and -s and -h and Windows.old )

It should return you to the prompt C:\   if it shows and ERROR then STOP - check the command
and if it was typed correctly you are not in the correct spot.



5.
Type this at the prompt and then hit ENTER

RD /s Windows.old

Should look like C:\>RD /s Windows.old
(there are SPACES between RD and /s and Windows.old )

Will return   Windows.old, are your sure Y/N   type Y

(If you get a message that you do not have Ownership Rights then issue this command
and hit ENTER )

TAKEOWN /f Windows.old /a /r

and repeat Step 5 - were you using an Elevated Command Prompt?


6: Type this at the prompt and then hit ENTER

DIR Windows.old

Should look like C:\>DIR Windows.old    -    and hit ENTER

It should return

Directory of C:\

File Not Found

Which confirms it is gone.


7. Close the COMMAND window

Hope this helps.


Rob Brown - Microsoft MVP <- profile - Windows Expert - Consumer : Bicycle <- Mark Twain said it right!

Rob Brown - Microsoft MVP - Windows and Devices for IT 2010 - current
Windows Insider MVP 2016 - current

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.