how to prevent the creation of system volume information folder in external hard drive

i am using both windows 8 and mac systems ... i like to know if it is possible not to create the system volume information folder in the external hard drive automatically...

the system volume information folders always show up in the mac system and it is quite annoying ... there is no need to have the system volume information folders in the external hard drive because the files are all not system files...

anyone has any idea how to stop the creation of svi folders?...

cheers,
Hi,
 

The System Volume Information folder is a hidden system folder that the System Restore tool uses to store its information and restore points. There is a System Volume Information folder on every partition on your computer.
 
You can prevent the system from creating restore points in your external hard drive by following these steps:
 
a) Press Windows key + F and type “System Restore” and click on the “settings” tab below
b) Click on “Create a restore point” in the search results
c) Now, in the new window, under “system protection” tab, select your External hard drive and click “Configure”
d) Click on “Disable System protection” and click Ok to save settings.
 
 
Now that you have disabled the restore points from being created on the external hard drive, you can now take ownership of the system volume information folder and delete it. System volume information folder is a hidden system folder and usually you don’t have access to it. So, you have to first take ownership of the folder and then delete it. Check out these steps:
 
a) Press Windows key + X, select control panel
b) Click on “Personalization and Appearance” and click on “Show hidden files and folders” under folder options
c) Now, go to the external hard drive and right click on the Volume system information folder and click on “properties”
d) Tap or click the “Security” tab, tap or click “Advanced”, and then tap or click “Change”
e) Type the name of the person you want to give ownership to and click “Check Names”
f) The user name that you’re giving ownership to should be display, click OK
g) If you want that person to be the owner of files and subfolders in this folder, select the “Replace owner on sub containers and objects” check box and click OK
h) Now, you can delete the folder.
 
Try these steps and let us know the results. Feel free to use this forum for any windows related queries; we’d be happy to help.

8 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

i followed the steps and i still can not delete the folders System Volume Information & $Recycle.Bin...
i can only delete the two folders System Volume Information & $Recycle.Bin when i use the external hard drive in mac...
is it possible to prevent the creation of the folders System Volume Information & $Recycle.Bin?...
there is no reason to have the creation of the folders System Volume Information & $Recycle.Bin in the external hard drive ... there is no system files or application files in the external hard drive...

the folders System Volume Information & $Recycle.Bin should only be created in the main drive C: drive to control all the partition drives & external hard drives ... it should only have one System Volume Information & $Recycle.Bin folders in drive C:...

cheers,

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,
 

The System Volume Information folder is a hidden system folder that the System Restore tool uses to store its information and restore points. There is a System Volume Information folder on every partition on your computer.
 
You can prevent the system from creating restore points in your external hard drive by following these steps:
 
a) Press Windows key + F and type “System Restore” and click on the “settings” tab below
b) Click on “Create a restore point” in the search results
c) Now, in the new window, under “system protection” tab, select your External hard drive and click “Configure”
d) Click on “Disable System protection” and click Ok to save settings.
 
 
Now that you have disabled the restore points from being created on the external hard drive, you can now take ownership of the system volume information folder and delete it. System volume information folder is a hidden system folder and usually you don’t have access to it. So, you have to first take ownership of the folder and then delete it. Check out these steps:
 
a) Press Windows key + X, select control panel
b) Click on “Personalization and Appearance” and click on “Show hidden files and folders” under folder options
c) Now, go to the external hard drive and right click on the Volume system information folder and click on “properties”
d) Tap or click the “Security” tab, tap or click “Advanced”, and then tap or click “Change”
e) Type the name of the person you want to give ownership to and click “Check Names”
f) The user name that you’re giving ownership to should be display, click OK
g) If you want that person to be the owner of files and subfolders in this folder, select the “Replace owner on sub containers and objects” check box and click OK
h) Now, you can delete the folder.
 
Try these steps and let us know the results. Feel free to use this forum for any windows related queries; we’d be happy to help.


I find it an absurd that Microsoft itself tell us things yelding no solution at all for so simple matter. Furthermore, the way folders and files are so much blocked that we must make a course to learn how to circunvent so many silly choices. Everybody complains about it and MS do nothing. I should respect the work of MS, of course, but for some aspects Windows should be freely distributed for people as a  beta product. Even if the updates stuff worked normally. People are really so tired of having pain in the neck with problems that truly idiocies and absurds. Cheers

5 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

This solution did not work for me. When in the settings for SYSTEM RESTORE, only the primary hard disk (C:) was shown in the list. The removable drive (a 32GB thumb drive) was not there. Instead, I did this:

Open a COMMAND WINDOW by typing CMD in the 'RUN' box, or by searching for CMD.

Navigate to the ROOT of the USB device (for me this was 'G:')

Type attrib -s -h -r "System Volume Information"

You will then need to delete any files in the directory.

type cd "System Volume Information"

type del *.*

You can then remove the directory

type cd\

type rd "System Volume Information"

That's it - directory now removed.

10 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Very good vettelover61 - that gets rid of the SVI folder once, but, even with System Restore turned off, how do you stop that folder from being created the next time you plug that 32GB UFD in please?

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Bump,

I also would like to know how to stop that folder from being created every time you plug in a drive. I have system restore turned off and it still is created. I do not need system restore since I have an external backup system.

3 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Unfortunately, until you take ownership of the folder, you cannot see who owns it or who created it.

However... the only other files I've ever seen with permissions that even lock out admins, have all been created and owned by the Trusted Installer user account. On that basis, assuming I'm correct, you have three options:

1. Format the card or pen drive in a legacy filesystem that does not have file security, such as FAT or FAT32
2. Set permissions on the root of the drive explicitly denying Trusted Installer permissions to create. (This will probably need to be done from an elevated cmd prompt or powershell.)
3. Create a group policy covering all removable drives, again, explicitly denying Trusted Installer permission to create.


HINT:

Trusted Installer is hidden from the usual views in local users or active directory. You need to specify it EXACTLY AS FOLLOWS. Enter it into the text box:

     NT Service\TrustedInstaller

Once you have typed that into the text box, click on "Check Names". If you typed everything correctly, you should see the text change to:

    Trusted Installer

When trusted Installer appears underlined in the text box, click OK

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thanks KevinWagener.

Your option 1 is no good for external hard drives >100GB that have to remain formatted NTFS.

Option 2 isn't much good in that as soon as the external drive is plugged in, the folders/files are written to the drive. If one doesn't want the drive altered in any way whatsoever (forensics), we want to prevent everything from being written to the drive at all times.

Option 3 might be a goer - it sounds intriguing.  I wonder if you could give step-by-step examples of doing that on Windows XP and Windows 7 for those of us who haven't a clue about setting up group policies please.

4 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

In my case  I didn't want anything to be written on the drive. The creation of the folder System Volume Information was causing me issues.

Because none of the solutions seemed to work for Windows 10 v1703, what I did and seems to be working is this:

  1. Delete contents of System Volume Information folder
  2. Delete the folder itself
  3. Create a new file with name System Volume Information

For #1 and 2 I used the command:

del /S /Q "Q:\System Volume Information" && rmdir "Q:\System Volume Information"

For #3 I used the command 

fsutil file createnew "Q:\System Volume Information" 0

You need to replace Q: with your drive letter.

Since we can't have a folder and a file with the same name, the System Volume Information folder can't be created.

4 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

 
 

Question Info


Last updated September 17, 2020 Views 24,389 Applies to: