Windows 8 Mail App keeps changing the Server Address to the wrong name

I am trying to link my Exchange 2010 mailbox to the Windows 8 Mail App.

But, every time I do, it changes the Server Address to blu-m.hotmail.com

So, since that is obviously not my Exchange server it keeps failing.

Any clue why it keeps doing this?

 

Question Info


Last updated March 24, 2018 Views 196 Applies to:

 

Hi MBarfield,

 

 

To troubleshoot the issues in which the Mail app cannot connect or configure with the Exchange server, I would suggest you to refer to the section: “How to troubleshoot an issue in which the Mail app cannot connect to the Exchange server” from the article: “How to configure an Exchange account and how to troubleshoot Exchange account connectivity issues in the Mail app in Windows 8 and Windows RT” given in this link:

 

http://support.microsoft.com/kb/2784275

 

For more information, you may also refer to these articles:

 

Supporting Windows 8 Mail in your organization

 

http://blogs.technet.com/b/exchange/archive/2012/11/26/supporting-windows-8-mail-in-your-organization.aspx

 

Set up your Office 365 or Exchange-based email in Windows 8 Mail

 

http://office.microsoft.com/en-us/web-apps-help/set-up-email-in-windows-8-mail-HA102834576.aspx#_Toc353444596

 

If the above articles were not helpful, then I would suggest you to post this query on the Microsoft Exchange Server Forums from this link:

 

http://social.technet.microsoft.com/Forums/en-US/category/exchangeserver

 

Hope this information is helpful.

 

 

Regards,
Rajesh Govind - Microsoft Support Engineer

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I finally resolved the issue (but not in a very good way).
 
As it turns out, it is because the Live account was renamed. I originally had a Live account that was using the SMTP address of my work email. Work is about to setup a federation with Microsoft, so as a result all Live accounts that were based on company domains would no longer work.
 
So, when I changed the Live account name, I figured I could setup the work email on Mail at that point (as it understandably had issues when they were the same). But, apparently, the original information is cached on the computer somewhere that I could not find. I even deleted the user profile and recreated it again from scratch, but it still was associating my work email as my Live account, so it kept updating the ‘Server Address’ pointing it to the Hotmail server.

I finally just reinstalled the entire operating system to clear where ever the data was cached. If anyone knows how this cached information can be cleared without reinstalling the operating system, I would appreciate it if they could share as it would be helpful knowing this if our user community starts running into this same issue as they update their Live accounts due to the pending federation.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.